php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53464 sqlite3 columnType() returns SQLITE3_NULL on bad column_number
Submitted: 2010-12-03 18:09 UTC Modified: 2010-12-11 16:12 UTC
From: danielc at analysisandsolutions dot com Assigned:
Status: Not a bug Package: SQLite related
PHP Version: 5.3SVN-2010-12-03 (SVN) OS: linux
Private report: No CVE-ID: None
 [2010-12-03 18:09 UTC] danielc at analysisandsolutions dot com
Description:
------------
The SQLite3Result::columnType() method returns SQLITE3_NULL (5) when column_number exceeds the column count.  It seems more appropriate for it to return FALSE.


Test script:
---------------
$db = new SQLite3(':memory:');

$db->exec('CREATE TABLE test (whatever INTEGER)');
$db->exec('INSERT INTO test (whatever) VALUES (1)');

$result = $db->query('SELECT * FROM test');
while ($row = $result->fetchArray(SQLITE3_NUM)) {
    var_dump($result->columnType(0));  // int(1)  [SQLITE3_INTEGER]

    // Seems returning false is more appropriate.
    var_dump($result->columnType(3));  // int(5)  [SQLITE3_NULL]
}

$result->finalize();
$db->close();

echo "Done\n";


Expected result:
----------------
int(1)
bool(false)
Done


Actual result:
--------------
int(1)
int(5)
Done


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-11 16:12 UTC] iliaa@php.net
-Status: Open +Status: Bogus
 [2010-12-11 16:12 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The return value is based on what libsqlite returns in this case.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 07:07:04 2023 UTC