php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #53358 API queries in php.ini
Submitted: 2010-11-19 17:47 UTC Modified: 2013-10-04 09:27 UTC
Votes:4
Avg. Score:3.5 ± 0.9
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: pophal at tubit dot tu-berlin dot de Assigned: mike
Status: Re-Opened Package: PHP options/info functions
PHP Version: * OS:
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-11-19 17:47 UTC] pophal at tubit dot tu-berlin dot de
Description:
------------
I would rather appreciate a php ini section analogous to [HOST=] querying the SAPI, e.g.

[SAPI=CLI]
extension = php-gtk2.so

in order to prevent the extension from being loaded when PHP is running as apache module or cgi. This would be helpful for distributions with like php.ini regardless of SAPI, in contrast to debian with its API-depending php.ini location.

A workaround is a modified shebang line:
#!/usr/bin/php -d extension=php_gtk2.so

but this cannot be considered a good solution.

Maybe this is not only php-gtk related.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-01 15:19 UTC] jani@php.net
-Package: *Configuration Issues +Package: PHP options/info functions -PHP Version: Irrelevant +PHP Version: *
 [2013-09-30 12:16 UTC] mike@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: mike
 [2013-09-30 12:16 UTC] mike@php.net
We already have SAPI INIs.
 [2013-10-04 09:27 UTC] mike@php.net
-Status: Closed +Status: Re-Opened
 [2013-10-04 09:27 UTC] mike@php.net
Sorry, there actually is a PR for that:
See bug #65681 and PR #466
https://github.com/php/php-src/pull/466
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC