php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53339 Fails to build LDAP module when compilng with gcc 4.5 and DSO libraries
Submitted: 2010-11-18 09:28 UTC Modified: 2011-03-18 19:47 UTC
From: clint at ubuntu dot com Assigned: geissert
Status: Closed Package: Compile Failure
PHP Version: 5.3.3 OS: Ubuntu Linux (natty)
Private report: No CVE-ID:
 [2010-11-18 09:28 UTC] clint at ubuntu dot com
Description:
------------
The currenty Ubuntu development release (natty) has updated the toolchain to gcc 
4.5 and uses DSO libs. Because of this, there are stricter restrictions on using 
symbols without directly linking to the library containing them.

This patch fixes these issues, and compiles correctly on natty and the current 
stable release (Ubuntu 10.10).

Test script:
---------------
./configure --with-ldap --with-openssl

Fails because sasl2 is not linked directly. If that is fixed,

make

Fails because libssl does not contain X509_new (libcrypto does).

Expected result:
----------------
configure and build should complete

Actual result:
--------------
checking for sasl_version in -lldap... no
configure: error: LDAP SASL check failed. Please check config.log for more 
information.
make: *** [configure-apache2-stamp] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2

ext/zip/lib/.libs/zip_dirent.o: In function `_zip_dirent_read':
/home/clint/pkg/php5/bzr/build-area/php5-5.3.3/ext/zip/lib/zip_dirent.c:478: 
warning: memset used with constant zero length parameter; this could be due to 
transposed parameters
/home/clint/pkg/php5/bzr/build-area/php5-5.3.3/ext/zip/lib/zip_dirent.c:478: 
warning: memset used with constant zero length parameter; this could be due to 
transposed parameters
/usr/bin/ld.bfd.real: ext/openssl/.libs/openssl.o: undefined reference to symbol 
'X509_free@@OPENSSL_0.9.8'
/usr/bin/ld.bfd.real: note: 'X509_free@@OPENSSL_0.9.8' is defined in DSO 
/lib64/libcrypto.so.0.9.8 so try adding it to the linker command line
/lib64/libcrypto.so.0.9.8: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

Patches

fix-ftbfs-and-dso.patch (last revision 2010-11-18 08:29 UTC) by clint at ubuntu dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-18 09:32 UTC] clint at ubuntu dot com
This is tracked in Ubuntu under this bug report:

https://bugs.launchpad.net/ubuntu/+source/php5/+bug/676672
 [2011-03-18 19:47 UTC] geissert@php.net
Automatic comment from SVN on behalf of geissert
Revision: http://svn.php.net/viewvc/?view=revision&revision=309398
Log: Add the libraries we actually test and need for LDAP and OpenSSL, fixes bug #53339
Patch by Clint Byrum
 [2011-03-18 19:47 UTC] geissert@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: geissert
 [2011-03-18 19:47 UTC] geissert@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2011-05-19 07:43 UTC] scottmac@php.net
Automatic comment from SVN on behalf of scottmac
Revision: http://svn.php.net/viewvc/?view=revision&revision=311223
Log: Revert part of the fix for #53339
On OSX we need ssl AND crypto

The patch that was applied didn't even match what was in the bug
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 10:03:03 2014 UTC