|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53284 Valgrind warnings in oci_set_* functions
Submitted: 2010-11-09 21:55 UTC Modified: 2010-11-10 19:51 UTC
From: Assigned: sixd
Status: Closed Package: OCI8 related
PHP Version: 5.3.3 OS: n/a
Private report: No CVE-ID:
 [2010-11-09 21:55 UTC]
Several oci_set functions use long instead of int for "s" lengths in 
zend_parse_parameters() calls


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-09 21:55 UTC]
-Assigned To: +Assigned To: sixd
 [2010-11-10 19:49 UTC]
Automatic comment from SVN on behalf of sixd
Log: Fixed bug #53284 (Valgrind warnings in oci_set_* functions)
 [2010-11-10 19:51 UTC]
-Status: Assigned +Status: Closed
 [2010-11-10 19:51 UTC]
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

A fix has been merged to svn PHP_5_3 and trunk branches.
It will be in any future OCI8 1.4.4+ and PHP 5.3.4+ releases
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 12:01:29 2015 UTC