php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53244 Connection failure with interbase
Submitted: 2010-11-05 01:13 UTC Modified: 2010-11-05 01:49 UTC
From: ice_and_hut at hotmail dot com Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.3.3 OS: Gentoo Linux
Private report: No CVE-ID: None
 [2010-11-05 01:13 UTC] ice_and_hut at hotmail dot com
Description:
------------
I am experiencing this behavior with any version of php after 5.2. I have compiled php with interbase support, but my adodb code fails on the following line. The firebird database is available (can connect with flamerobin), im using the latest version of adodb (5.11). Initially I thought it had something to do with the adodb-ext package, but after removing that and delving into the adodb package code (drivers/adodb-ibase.inc.php), this is where it fails.

if (!function_exists('ibase_pconnect')) return null;

Seeing as I have compiled php with interbase support and my function call to what should be a local php function fails, I see this as a bug.

Any assistance would be appreciated.

Test script:
---------------
require_once("adodb.inc.php"); //ADOdb library

$db_host = "localhost";
$db_username = "username";
$db_password = "password";
$database = "/var/lib/firebird/database.fdb";

$db = NewADOConnection("firebird");
$db->debug = true; //turn on debug msgs
$db->dialect = 3;
$db->autoCommit = true;
$db->PConnect($db_host,$db_username,$db_password,$database); // <---- fails 
$db->SetFetchMode(ADODB_FETCH_ASSOC);
if (!$db) {
  die("Connection failed");
}

Expected result:
----------------
no output as the connection is successful

Actual result:
--------------
localhost: Missing extension for ibase

messing with the adodb-ibase.inc.php file and commenting out line 66

Fatal error: Call to undefined function ibase_pconnect() in /usr/share/php5/adodb/drivers/adodb-ibase.inc.php on line 73 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-05 01:49 UTC] felipe@php.net
-Status: Open +Status: Bogus
 [2010-11-05 01:49 UTC] felipe@php.net
The php-interbase module is not being loaded.
 [2010-11-05 02:13 UTC] ice_and_hut at hotmail dot com
If this is the case, how do we load this module? I have never had to load it in the past?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 15:01:28 2020 UTC