php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53149 cURL extension crashes Apache server on start-up
Submitted: 2010-10-25 13:54 UTC Modified: 2011-02-08 16:52 UTC
From: Jondor at GMX dot net Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.3.3 OS: Windows 7
Private report: No CVE-ID: None
 [2010-10-25 13:54 UTC] Jondor at GMX dot net
Description:
------------
The Apache web server (version 2.2.17) on Windows 7 (32-bit) fails to start whenever the cURL extension is enabled in php.ini. Disabling cURL by commenting out the line "extension=php_curl.dll" fixes the problem. All other extensions work fine.

In other words, installing the thread-safe PHP 5.3.3 for Apache on Windows (php-5.3.3-Win32-VC6-x86.msi from windows.php.net) with all default extensions crashed the web server on my system without any sensible error message. The culprit was the cURL extension.

Expected result:
----------------
The PHP installer does not crash the web server, or at least exits with an  error message (in php-errors.log).



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-25 16:20 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2010-10-25 16:20 UTC] cataphract@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2010-10-26 17:37 UTC] Jondor at GMX dot net
-Status: Feedback +Status: Open
 [2010-10-26 17:37 UTC] Jondor at GMX dot net
Tried to generate the backtrace using the Microsoft Debug Diagnostic Tools. Couldn't get it to work for the Apache2.2 service (instructions are for php.exe). I'm probably not savvy enough. Sorry.
 [2010-10-26 17:47 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-10-26 17:47 UTC] pajoye@php.net
Duplicated, you can try using the zip version please? Not the MSI. Simply replace the php_curl.dll
 [2010-10-27 11:33 UTC] Jondor at GMX dot net
-Status: Feedback +Status: Closed
 [2010-10-27 11:33 UTC] Jondor at GMX dot net
I tried that already before submitting the original report. However, meanwhile I identified the cause of the problem. In my system's search path (%PATH% environment variable), the PHP directory was preceded by another directory which also included the libeay32.dll that the cURL extension depends on. Therefore it loaded that other version of libeay32.dll which apparently isn't compatible with this PHP build. Changing the search order fixed the problem.
 [2010-10-27 17:41 UTC] pajoye@php.net
-Status: Closed +Status: Bogus
 [2010-10-27 17:41 UTC] pajoye@php.net
Not a bug in PHP > config error.
 [2011-02-08 16:24 UTC] info at cybrax dot com
Same problem on Win XP SP3, Apache 2.2 and PHP 5 CuRL will crash apache on 
startup, everything runs fine except when loading the curl extension.

Also tried to create a backtrace, sadly failed, Visual Studio debugger reports the 
problem occures in php5ts.dll.

Tried Both MSI and ZIP, According to google this is a problem that more people 
have.
 [2011-02-08 16:52 UTC] pajoye@php.net
Right, many people seems to have issue to correctly set their PATH or where to put 
DLLs. Not sure what we can do at this point. But there is no bug here.
 [2011-02-08 16:57 UTC] info at cybrax dot com
Updating to PHP 5.2.17 Fixes this problem.

Thank you.
 [2011-09-13 07:27 UTC] donatas at infosys dot lt
I've found out that this problem with php_curl failing to start after updating php to 5.3 indeed came from libeay32.dll, the libeay32.dll that was in my Apache2/bin directory - never thought to look there for any error. 
Renaming/removing Apache2/bin/libeay32.dll and restarting Apache fixed the problem.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 14:01:29 2019 UTC