php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #5311 implement checkdnsrr() and getmxrr() on windows
Submitted: 2000-07-01 16:36 UTC Modified: 2010-03-18 16:34 UTC
Votes:9
Avg. Score:4.6 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:1 (14.3%)
Same OS:4 (57.1%)
From: steve at tradinglinx dot com Assigned: kalle (profile)
Status: Closed Package: *General Issues
PHP Version: 4.0.1 OS: W2000
Private report: No CVE-ID: None
 [2000-07-01 16:36 UTC] steve at tradinglinx dot com
OS : Windows 2000 Pro
Server : Apache 1.3.12 Win32
PHP4 : PHP 4.01 Win32
Script : ---------------------------------
list($user,$domain)=split("@",$email,2);
echo "<P>$user @ $domain
if (checkdnsrr($domain,"MX")){
echo "<P>Valid Domain</P>"
}
else{
echo "<P>UnValid Domain</P>"
}
-------------------------------------------
Test is already Unvalid Domain, But split is OK.
I supposed that it's checkdnsrr not working.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-12 13:50 UTC] waldschrott@php.net
user comment:
Neither checkdnsrr nor getmxrr appear work under Windows NT
4/SP6a with IIS
4.

I'm running with the downloaded Windows binary 4.0.1pl2 and
the provided
.ini file. OS is NT 4.0/sp6a, IIS 4.

Under Windows, checkdnsrr always returns "true" (no matter
whether the
provided domain name could even possibly be valid) and
getmxrr returns 0
hosts.

(append ?domain=domaintotest.com to the URL when calling
this script)

<?
echo("<p>checkdnsrr:
".(checkdnsrr($domain,"MX")?"true":"false"));
getmxrr($domain,$mxhosts);
echo("<p>getmxrr: [".count($mxhosts)."] ");
for ( $i = 0; $i < count ( $mxhosts ); $i++ ) {
    echo($mxhosts[$i]." ");
    }
?>

 [2001-02-24 13:47 UTC] jmoore@php.net
Both of these are #Defined out in the source code.. someone needs too look for a win32 implmentation of these at some point (dns.c:170 #if HAVE_BINDLIB && !(defined(__BEOS__)||defined(PHP_WIN32))).

Changing to Feature Change Request.
 [2003-01-28 18:28 UTC] pollita@php.net
Windows users can get this functionality from the PEAR class Net_DNS.

http://pear.php.net/net_dns
 [2009-01-06 20:52 UTC] pajoye@php.net
As a new year present, all DNS functions are now available on windows, 5.3 and 6 (head).

Waiting my extra slice of cakes.
 [2009-01-06 21:50 UTC] pajoye@php.net
> tbd
 [2009-01-06 22:31 UTC] php at hm2k dot org
I love the fact that I was just writing about this as it was updated: http://www.hm2k.com/posts/php-getmxrr-support-for-windows

*grin*
 [2010-03-18 16:34 UTC] kalle@php.net
-Status: To be documented +Status: Closed -Package: Feature/Change Request +Package: *General Issues
 [2010-03-18 16:34 UTC] kalle@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

Already fixed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 19:01:23 2020 UTC