php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52974 jewish.c: compile error under Windows with GBK charset
Submitted: 2010-10-02 22:10 UTC Modified: 2018-07-22 15:21 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: xiaomao5 at live dot com Assigned: cmb (profile)
Status: Closed Package: Compile Failure
PHP Version: 5.3.3 OS: Windows 7
Private report: No CVE-ID: None
 [2010-10-02 22:10 UTC] xiaomao5 at live dot com
Description:
------------
there is an encoding problem in the file. the month name are messed up with quotes and line endings and cause C2001 error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-03 00:00 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2010-10-03 00:00 UTC] cataphract@php.net
You have to give more details -- the actual error, how did you get the source, etc.

Looking at the file in 5.3.3, I see nothing obvious that could have caused this:

http://svn.php.net/viewvc/php/php-src/tags/php_5_3_3/ext/calendar/jewish.c?revision=301440&view=markup
 [2010-10-03 03:47 UTC] xiaomao5 at live dot com
-Status: Feedback +Status: Open
 [2010-10-03 03:47 UTC] xiaomao5 at live dot com
Found at php-5.3.3.tar.bz2 no changes have been done since extarcting
 [2010-10-03 10:43 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2010-10-03 10:43 UTC] cataphract@php.net
Please give information such as:

* The compiler
* The actual error message, including the line wherein it occurred
* Your codepage (type chcp in the command prompt before compiling PHP from there)
* The procedure you used to compile PHP
* Anything else that you may find relevant to the resolution of this problem

In future, please provide all the possibly relevant information in the bug report. See also http://bugs.php.net/how-to-report.php
 [2011-03-21 06:17 UTC] zhangsilly at gmail dot com
this problem is still in PHP 5.3.6. The same problem is in 
ext/standard/browscap.c, in the line 61.

My OS is Windows 7 & Windows XP.Compiler is Visual Studio 2008.But , I think is 
not matter with compiler, when i use Editplus to view these files, Thy cann't show 
correct,not matter i choose the encoding with ANSI/GBK or UTF-8.
 [2013-02-18 00:34 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 [2013-05-10 09:13 UTC] zhaoyong dot lc at gmail dot com
I find this problem too in PHP 5.3.17, I want to complie PHP in Windows but error 
"jewish.c(324) : error C2001" is throwed out.

My OS is Windows 7 with GBK character set and Compiler is Visual Studio 2008. It
also can't be corrent by changing encoding and character set.
 [2013-05-16 19:43 UTC] aharvey@php.net
Reopening. GBK seems to be a common theme here, and line 326 includes ISO-8859-8 encoded Hebrew which iconv suggests is invalid in GBK.
 [2013-05-16 19:43 UTC] aharvey@php.net
-Status: No Feedback +Status: Open
 [2013-10-10 09:41 UTC] xjoywag at 163 dot com
My envirement:
OS: Windows 7 64bit / Complier: VS 2012 and using 64bit to build PHP

I meet the same question when build a php 5.5. Following is the way to issue it:
1. Open VS 2012, open "Files->Open->File", select "jewish.c".
2. Click "Open" button's "down arrow", click "Open Way"
3. In the "Open Way" dialog, select "C++ source editor(with encoding function)" and set it to "default". Click "OK".
4. Now, pop a new encoding dialog showing "auto-check" option.
5. Click "down arrow" to show all options and select "Hebrew(Windows) - code page 1255". Click button "OK".
6. Ok, the file is opened no any prompt and can find those Hebrew words.
7. let's do the most important operation. Open "Files->Advanced Save Options".
8. Now, select "Unicode - code page 1200" from Encoding dialog. Click "OK".
9. I think none want to edit this file next, so open "Files->Save" or "Ctrl+S" ( and close VS).

buildconf --force, configure ..., nmake again :) maybe should delete Release-TS too.

Sorry, I use Chinese VS 2012, so translate menus/dialogs to English for comment.
 [2018-07-22 15:21 UTC] cmb@php.net
-Summary: Calendar Extension jewish.c +Summary: jewish.c: compile error under Windows with GBK charset -Assigned To: +Assigned To: cmb
 [2018-07-22 16:20 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=php-src.git;a=commit;h=99fdf5916eccbd72c10cc4d84693e677996b1229
Log: Fix #52974: jewish.c: compile error under Windows with GBK charset
 [2018-07-22 16:20 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Sep 26 11:01:26 2018 UTC