php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52792 core dump
Submitted: 2010-09-07 11:25 UTC Modified: 2010-11-09 09:56 UTC
From: ken73 dot chen at gmail dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 5.3.3 OS: FreeBSD 7.2
Private report: No CVE-ID: None
 [2010-09-07 11:25 UTC] ken73 dot chen at gmail dot com
Description:
------------
db4# php -m
[PHP Modules]
Core
date
ereg
json
libxml
memcached
pcre
Reflection
session
SPL
standard
xml

[Zend Modules]

Segmentation fault (core dumped)

The problem only occur when memcached extension is loaded.



Actual result:
--------------
db4# gdb /usr/local/bin/php php.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...
Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libcrypt.so.4...done.
Loaded symbols for /lib/libcrypt.so.4
Reading symbols from /usr/local/lib/libpcre.so.0...done.
Loaded symbols for /usr/local/lib/libpcre.so.0
Reading symbols from /lib/libm.so.5...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /usr/local/lib/libxml2.so.5...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /lib/libz.so.4...done.
Loaded symbols for /lib/libz.so.4
Reading symbols from /usr/local/lib/libiconv.so.3...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /lib/libc.so.7...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /libexec/ld-elf.so.1...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x000000007b5647b0 in ?? ()
(gdb) bt
#0  0x000000007b5647b0 in ?? ()
#1  0x000000007a74b7d5 in xmlFreeMutex () from /usr/local/lib/libxml2.so.5
#2  0x000000007a74b215 in xmlCleanupGlobals () from /usr/local/lib/libxml2.so.5
#3  0x000000007a6e3d3a in xmlCleanupParser () from /usr/local/lib/libxml2.so.5
#4  0x000000000045f338 in php_libxml_shutdown () at /usr/ports/lang/php5/work/php-5.3.3/ext/libxml/libxml.c:583
#5  0x000000000045f823 in zm_shutdown_libxml (type=1, module_number=3) at /usr/ports/lang/php5/work/php-5.3.3/ext/libxml/libxml.c:655
#6  0x00000000005c6b26 in module_destructor (module=0x7af61270) at /usr/ports/lang/php5/work/php-5.3.3/Zend/zend_API.c:2098
#7  0x00000000005ce1f4 in zend_hash_apply_deleter (ht=0x8b4460, p=0x7afbd4c0) at /usr/ports/lang/php5/work/php-5.3.3/Zend/zend_hash.c:611
#8  0x00000000005ce35a in zend_hash_graceful_reverse_destroy (ht=0x8b4460) at /usr/ports/lang/php5/work/php-5.3.3/Zend/zend_hash.c:646
#9  0x00000000005bc888 in zend_shutdown () at /usr/ports/lang/php5/work/php-5.3.3/Zend/zend.c:759
#10 0x0000000000548aad in php_module_shutdown () at /usr/ports/lang/php5/work/php-5.3.3/main/main.c:2138
#11 0x00000000006abff6 in main (argc=2, argv=0x7fffffffec68) at /usr/ports/lang/php5/work/php-5.3.3/sapi/cli/php_cli.c:1387
(gdb) frame 4
#4  0x000000000045f338 in php_libxml_shutdown () at /usr/ports/lang/php5/work/php-5.3.3/ext/libxml/libxml.c:583
583			xmlCleanupParser();
(gdb) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-07 11:33 UTC] pajoye@php.net
-Status: Open +Status: Bogus
 [2010-09-07 11:33 UTC] pajoye@php.net
Report the issue to the memcached developers at PECL
 [2010-09-07 11:41 UTC] ken73 dot chen at gmail dot com
I have done, but developers thinks the problem is on libxml2.
developers 

http://pecl.php.net/bugs/bug.php?id=18509
 [2010-09-08 20:03 UTC] andrei@php.net
What version of memcached extension is it? I'm not sure what I can do at this 
point, because libxml + memcached works normally for me (and does for other 
people) and I don't have a FreeBSD machine to debug this on.
 [2010-09-09 04:04 UTC] ken73 dot chen at gmail dot com
The version of memcached is 1.0.2.

I try to install memcached on 5 FreeBSD machines. On FreeBSD 6.2 and 8.0, it's okay. On three FreeBSD 7.2 machines, the core dumped.
 [2010-11-09 09:47 UTC] karavan01 at yandex dot ru
I have the same problem... FreeBSD 7.3 amd64
All versions are up to date... php5_5.3.3_2, libmemcached-0.44, pecl-memcached-1.0.2

If I write "extension=memcached.so" before "extension=session.so" in extensions.ini, than I get:
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20090626/memcached.so' - /usr/local/lib/php/20090626/memcached.so: Undefined symbol "php_session_create_id" in Unknown on line 0

and if after it... segmentation fault without core dump. I can't find any hints to fix the problem....
 [2010-11-09 09:56 UTC] aharvey@php.net
-Block user comment: N +Block user comment: Y
 [2010-11-09 09:56 UTC] aharvey@php.net
The PECL bug is the appropriate place to discuss this bug, not here.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 18 05:01:23 2021 UTC