php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52735 config values should be trimed
Submitted: 2010-08-30 09:16 UTC Modified: 2010-08-30 12:19 UTC
From: miha dot vrhovnik at domenca dot com Assigned: fat (profile)
Status: Closed Package: FPM related
PHP Version: 5.3.3 OS: any
Private report: No CVE-ID: None
 [2010-08-30 09:16 UTC] miha dot vrhovnik at domenca dot com
Description:
------------
Starting php5-fpm Aug 30 06:58:21.982996 [ALERT] [pool www] pm.min_spare_servers(0) must be a positive value
Aug 30 06:58:21.983104 [ERROR] failed to post process the configuration
 failed

The problem is that after the actual value (number) I had a space.
This problem might effect other config variables also. 
Solution for this is obvious. All settings? should be trimmed first, before put to use.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-30 09:21 UTC] fat@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: fat
 [2010-08-30 10:58 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2010-08-30 10:58 UTC] fat@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

It's been corrected in revision 302531 several days ago.
 [2010-08-30 12:19 UTC] miha dot vrhovnik at domenca dot com
-Status: Feedback +Status: Closed
 [2010-08-30 12:19 UTC] miha dot vrhovnik at domenca dot com
It seems that it really is fixed. Closing
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC