php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #52708 New PDO::quoteIdentifier($name) method
Submitted: 2010-08-26 17:15 UTC Modified: 2010-08-27 06:01 UTC
From: ch@php.net Assigned:
Status: Duplicate Package: PDO related
PHP Version: 5.3.3 OS:
Private report: No CVE-ID: None
 [2010-08-26 17:15 UTC] ch@php.net
Description:
------------
Sometimes it would be very useful to have a PDO::quoteIdentifier($name) method
for the same reasons there already is a PDO::quote($name) method i.e. because the quoting characters might be different among database engines and to prevent SQL-Injection-Attacks.

Implementing it shouldn't be hard as the lower level DB engines provide a corresponding function or if not, the ANSI SQL quoting character could be used as fall-back.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-27 06:01 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2010-08-27 06:01 UTC] aharvey@php.net
Dupe of request #38196.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Sep 19 10:01:26 2019 UTC