php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52704 php.ini error for error_log parameter
Submitted: 2010-08-26 05:27 UTC Modified: 2010-08-26 21:00 UTC
Votes:3
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: pfenderd at bellsouth dot net Assigned:
Status: Wont fix Package: PHP options/info functions
PHP Version: 5.2.14 OS: Windows Vista Ultimate - 32bit
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-08-26 05:27 UTC] pfenderd at bellsouth dot net
Description:
------------
Using IIS7 in ISAPI mode, the php.ini file is not allowed to change the value of error_log.
When installed, 
error_log="C:\Windows\temp\php-errors.log"
Attempted to change to a new folder path
error_log="C:\PHP\logs\php-errors.log"

It worked properly with the windows temp folder, but not the next location.
The "C:\PHP\logs" folder has full permissions for anyone.  The file "php-errors.log" is created by PHP in the new folder when it starts processing a web page, but then generates error 500.

There are 31 websites running on this server. They all ran properly with PHP version 5.2.6, but all fail with 5.2.14.  Changing back to the windows temp folder always makes PHP work properly.  This is a repeatable problem.  It is not related to the content of the PHP file being parsed.

There is no problem with the parameters for "upload_tmp_dir=" and "session.save_path=" using the new folder:
upload_tmp_dir="C:\PHP\tmp"
session.save_path="C:\PHP\tmp"



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-26 19:28 UTC] pajoye@php.net
How do you change it? In the same php.ini?

However, the ISAPI is not supported anymore. The FastCGI is the interface being recommended to be used with IIS (all versions).
 [2010-08-26 19:29 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-08-26 20:21 UTC] pfenderd at bellsouth dot net
-Status: Feedback +Status: Open
 [2010-08-26 20:21 UTC] pfenderd at bellsouth dot net
I changed the file designations in the php.ini that was generated by the 
installer program.

If "the ISAPI is not supported anymore", then why is there an option for it in 
the installation program?  Other than trying to specify a different location for 
the error_log parameter, the ISAPI version seems to work properly.

I will try installing with the FastCGI option to see if that works with the new 
error_log location.

I just re-installed using the installation file "php-5.2.14-Win32-VC6-x86.msi" 
from the windows.php.net website with the same error.  This fixed the bug 
#52705.
 [2010-08-26 20:40 UTC] pfenderd at bellsouth dot net
I just re-installed PHP 5.2.14 using the FastCGI option.
Now the error_log location works properly.
It seems that the problem was in the ISAPI version.
This option should really be removed from the installation procedure.
 [2010-08-26 21:00 UTC] pajoye@php.net
-Status: Open +Status: Wont fix
 [2010-08-26 21:00 UTC] pajoye@php.net
It is, in 5.3+
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 07:01:26 2019 UTC