php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52615 Blank status page
Submitted: 2010-08-16 05:13 UTC Modified: 2010-08-18 16:00 UTC
From: vlad at vladgh dot com Assigned: fat (profile)
Status: Not a bug Package: FPM related
PHP Version: 5.3.3 OS: Ubuntu 10.04
Private report: No CVE-ID: None
 [2010-08-16 05:13 UTC] vlad at vladgh dot com
Description:
------------
I have php 5.3.3 installed from sources with nginx. FPM is working with the status page activated and working correctly. My problem is that a few days ago my status page suddenly stopped working. It just shows a blank with status 200. I ruled out nginx as the culprit. Is there anything I ca do about this.

Thank you in advance,
Vlad.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-16 05:21 UTC] aharvey@php.net
-Status: Open +Status: Bogus
 [2010-08-16 05:21 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2010-08-18 14:27 UTC] fat@php.net
-Status: Bogus +Status: Feedback -Assigned To: +Assigned To: fat
 [2010-08-18 14:27 UTC] fat@php.net
what is the last value of accepted conn you had before it returns a blank page ?

did you change anything on the nginx or FPM conf before it stopped working ?
 [2010-08-18 15:47 UTC] vlad at vladgh dot com
-Status: Feedback +Status: Assigned
 [2010-08-18 15:47 UTC] vlad at vladgh dot com
It was somewhere in the range of 1 mil connections. Thank you for restarting this thread but I had to do a clean reinstall of my server, with a new configuration for both fpm and nginx, and it is working properly so far. But in the end I suspect nginx of being the culprit because everything else was working except the status page.

Thank you anyway,
Vlad.
 [2010-08-18 15:53 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2010-08-18 15:53 UTC] fat@php.net
Hum to be sure, which status page are you talking about : the nginx one or the 
FPM one ? I'm now confused.

Does it look like this ?

accepted conn	155132211
pool	www_chroot
process manager	static
idle processes	97
active processes	3
total processes	100
 [2010-08-18 15:59 UTC] vlad at vladgh dot com
-Status: Feedback +Status: Assigned
 [2010-08-18 15:59 UTC] vlad at vladgh dot com
Yes I was talking about the FPM status page activated by pm.status_path in php-fpm.conf. But like I said, I reinstalled everything and now it works. I will let you know if the problem reappears. Thank you.
 [2010-08-18 16:00 UTC] fat@php.net
-Status: Assigned +Status: Bogus
 [2010-08-18 16:00 UTC] fat@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

OK reup this bug if needed
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC