php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #52506 Remove "final" modifier from exception's methods
Submitted: 2010-07-31 16:19 UTC Modified: 2020-03-28 15:53 UTC
Votes:6
Avg. Score:3.8 ± 1.1
Reproduced:4 of 5 (80.0%)
Same Version:3 (75.0%)
Same OS:3 (75.0%)
From: giorgio dot liscio at email dot it Assigned:
Status: Re-Opened Package: Class/Object related
PHP Version: Next Major Version OS: all
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-07-31 16:19 UTC] giorgio dot liscio at email dot it
Description:
------------
hi, it is possible to remove the final modifier from the defined methods in Exception?

they are incredibly limiting

thank you


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-05 06:28 UTC] crrrodriguez at opensuse dot org
Nope, See http://php.net/language.exceptions.extending.php
 [2010-08-06 07:33 UTC] giorgio dot liscio at email dot it
i know, but it is a request
 [2010-08-16 02:03 UTC] cataphract@php.net
-Type: Bug +Type: Feature/Change Request
 [2020-03-28 15:47 UTC] carusogabriel@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: carusogabriel
 [2020-03-28 15:47 UTC] carusogabriel@php.net
Since PHP 7, we have the Throwable interface (https://php.net/throwable), which solves this problem.
 [2020-03-28 15:49 UTC] nikic@php.net
@carusogabriel: How does Throwable help here? Userland implementations of Throwable are forbidden.
 [2020-03-28 15:53 UTC] carusogabriel@php.net
-Summary: remove "final" from exception's methods +Summary: Remove "final" modifier from exception's methods -Status: Closed +Status: Re-Opened -PHP Version: 5.3.3 +PHP Version: Next Major Version -Assigned To: carusogabriel +Assigned To:
 [2020-03-28 15:53 UTC] carusogabriel@php.net
@nikic: My bad, I thought that we allowed this kind of implementation: https://3v4l.org/TnoBh.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 14:01:24 2020 UTC