php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52473 Large Objects not read
Submitted: 2010-07-28 16:43 UTC Modified: 2012-03-31 10:37 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: stefan dot kirchev at gmail dot com Assigned: yohgaki (profile)
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.2.14 OS: Linux
Private report: No CVE-ID: None
 [2010-07-28 16:43 UTC] stefan dot kirchev at gmail dot com
Description:
------------
Function pg_lo_read_all returns 0 bytes read.
Database: (PostgreSQL) 9.0beta3


Test script:
---------------
...
header('Content-type: image/jpeg');

$db->begin();
$handle = pg_lo_open($link, $oid, "r");
pg_lo_read_all($handle);
$db->commit();
...

Expected result:
----------------
Problem appeared after postgres and php upgrade.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-29 20:42 UTC] tommy at gildseth dot com
Aside from the fact that version 9.0 of PostgreSQL is still beta, you haven't provided a complete test case that anyone can use to reproduce your problem. You also did not say anything about which PHP or Postgres versions you upgraded from.

All that said though, this could be related to the fact that the behaviour of access permissions on LOB's in PostgreSQL 9 has changed from previous versions. The change being that previously, there was no access restrictions. My guess therefore, is that this is not a PHP-related error.
 [2012-03-31 06:08 UTC] yohgaki@php.net
Was the previous comment guess right?
 [2012-03-31 06:08 UTC] yohgaki@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: yohgaki
 [2012-03-31 10:37 UTC] yohgaki@php.net
-Status: Feedback +Status: Not a bug
 [2012-03-31 10:37 UTC] yohgaki@php.net
Got reply from owner via mail. It was permission.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 15:01:31 2024 UTC