php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52417 MySQLi build failure with mysqlnd
Submitted: 2010-07-23 14:49 UTC Modified: 2010-08-16 12:56 UTC
Votes:9
Avg. Score:4.9 ± 0.3
Reproduced:9 of 9 (100.0%)
Same Version:9 (100.0%)
Same OS:9 (100.0%)
From: php-bugs-2010 at ryandesign dot com Assigned: mysql
Status: Closed Package: MySQLi related
PHP Version: 5.3.3 OS: Mac OS X 10.6.4
Private report: No CVE-ID:
 [2010-07-23 14:49 UTC] php-bugs-2010 at ryandesign dot com
Description:
------------
Building mysqli with mysqlnd fails for me (contrary to the report in bug #52413 
which says using an external libmysql fails but using mysqlnd succeeds).

Actual result:
--------------
/usr/bin/gcc-4.2 ${wl}-undefined ${wl}dynamic_lookup -o .libs/mysqli.so -bundle  
.libs/mysqli.o .libs/mysqli_api.o .libs/mysqli_prop.o .libs/mysqli_nonapi.o 
.libs/mysqli_fe.o .libs/mysqli_report.o .libs/mysqli_driver.o 
.libs/mysqli_warning.o .libs/mysqli_exception.o  -L/opt/local/lib  -arch x86_64 -
arch x86_64
ld: duplicate symbol _mysqlnd_globals in .libs/mysqli_api.o and .libs/mysqli.o
collect2: ld returned 1 exit status
make: *** [mysqli.la] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-08 23:51 UTC] php-bugs-2010 at ryandesign dot com
I should add that I am the maintainer of PHP for MacPorts. What can we do to fix 
this problem today so that mysqli can build? This bug and bug #52413 had blocked 
us from updating PHP to 5.3.3. I just did update it anyway, leaving php5-mysql at 
version 5.3.2 since our sysadmin said that seemed to work, but we've now found 
php5-mysql 5.3.2 cannot build with PHP 5.3.3 so unless a solution is forthcoming 
we'll have to downgrade all of PHP to 5.3.2 again.
 [2010-08-14 20:41 UTC] Felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mysql
 [2010-08-16 11:44 UTC] andrey@php.net
Automatic comment from SVN on behalf of andrey
Revision: http://svn.php.net/viewvc/?view=revision&revision=302331
Log: Sync with trunk, fixes build failure on MacOSX.
Fix for Bug #52417 MySQLi build failure with mysqlnd
 [2010-08-16 12:56 UTC] andrey@php.net
Fix will be in 5.3.4 . The bug doesn't exist in trunk

Thanks!
 [2010-08-16 12:56 UTC] andrey@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 07:02:02 2014 UTC