php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52416 compilation fails when building mysqli
Submitted: 2010-07-23 13:07 UTC Modified: 2010-07-23 13:12 UTC
From: rs at bytecamp dot net Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 5.3.3 OS: FreeBSD 8.1-RC2
Private report: No CVE-ID:
 [2010-07-23 13:07 UTC] rs at bytecamp dot net
Description:
------------
When compiling PHP from source, it bails out on building mysqli with the following error:

In file included from /root/bc_www_contrib/php-5.3/php-5.3.3/ext/mysqli/php_mysqli_structs.h:57,
                 from /root/bc_www_contrib/php-5.3/php-5.3.3/ext/mysqli/mysqli.c:33:
/usr/local/include/mysql/my_global.h:918: error: duplicate 'unsigned'
/usr/local/include/mysql/my_global.h:918: warning: useless type name in empty declaration


The version of the MySQL client lib is: mysql-client-5.0.90

Test script:
---------------
./configure \
        --prefix=$PREFIX --with-config-file-path=$PREFIX/etc \
        --disable-ipv6 \
        --enable-hash \
        --enable-libxml=shared --enable-xml=shared \
        --enable-xmlreader=shared --enable-xmlwriter=shared \
        --enable-wddx=shared --with-xsl=shared \
        --with-openssl=shared \
        --enable-ftp=shared \
        --with-zlib=shared --with-bz2=shared \
        --enable-calendar=shared \
        --enable-ctype=shared \
        --with-curl=shared \
        --enable-dba=shared \
        --enable-exif=shared \
        --enable-fileinfo=shared \
        --enable-filter=shared \
        --with-gd=shared \
        --with-png-dir \
        --with-jpeg-dir \
        --with-freetype-dir \
        --enable-gd-native-ttf \
        --with-gettext=shared \
        --with-mhash=shared \
        --with-iconv=shred \
        --enable-dom=shared \
        --enable-mbstring=shared \
        --with-mcrypt=shared \
        --enable-json=shared \
        --disable-mbregex \
        --with-mysql=shared \
        --with-mysqli=shared \
        --enable-pdo=shared --with-pdo-pgsql=shared --with-pdo-mysql=shared --with-pdo-sqlite=shared \
        --with-pgsql=shared \
        --enable-phar=shared \
        --enable-posix=shared \
        --with-pspell=shared \
        --with-recode=shared \
        --enable-session \
        --enable-simplexml=shared \
        --enable-soap=shared \
        --enable-sockets=shared \
        --with-sqlite=shared \
        --enable-sqlite-utf8 \
        --enable-tokenizer=shared \
        --enable-zip=shared

make


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-23 13:12 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2010-07-23 13:12 UTC] aharvey@php.net
Duplicate of bug #52413.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 22:02:05 2014 UTC