php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #52377 Add .user.ini support to FPM
Submitted: 2010-07-19 13:10 UTC Modified: 2010-07-23 08:35 UTC
From: pch at ordbogen dot com Assigned:
Status: Not a bug Package: FPM related
PHP Version: 5.3.2 OS:
Private report: No CVE-ID: None
 [2010-07-19 13:10 UTC] pch at ordbogen dot com
Description:
------------
If would be nice if the FastCGI Process Manager SAPI supported .user.ini files 
like the ordinary FastCGI SAPI does. Although you can specify per-pool php.ini 
for FPM, it really doesn't give you the same flexibility as .htaccess and 
.user.ini does.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-23 00:03 UTC] fat@php.net
-Status: Open +Status: Bogus
 [2010-07-23 00:03 UTC] fat@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

.user.ini works as excepted in FPM. If you're experimenting a real bug, please 
provide some more infos.
 [2010-07-23 08:35 UTC] pch at ordbogen dot com
My bad.

I thought FPM was a part of PHP 5.3.2, since the modules from php53.dotdeb.org 
included it. But apparently FPM was added through patches, and these patches did 
not parse .user.ini-files. I see that PHP 5.3.3 was released yesterday, and 
judging from 
a grep through the source, FPM does in fact parse .user.ini-files as you said.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC