php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52209 INPUT_ENV returns NULL for set variables (CLI)
Submitted: 2010-06-30 13:05 UTC Modified: 2010-12-22 17:19 UTC
From: ch@php.net Assigned: iliaa
Status: Closed Package: Filter related
PHP Version: 5.3.2 OS: Linux
Private report: No CVE-ID:
 [2010-06-30 13:05 UTC] ch@php.net
Description:
------------
This is almost the same as #49184 just that I tried INPUT_ENV instead of INPUT_SERVER.


Test script:
---------------
$ cat foo.php 
<?php
var_dump( filter_input(INPUT_SERVER, 'PWD') );
var_dump( $_ENV['PWD'] );


Expected result:
----------------
  string(15) "/srv/home/james"
  string(15) "/srv/home/james"

Actual result:
--------------
  NULL
  string(15) "/srv/home/james"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-22 17:19 UTC] iliaa@php.net
Automatic comment from SVN on behalf of iliaa
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=306575
Log: Fixed bug #52209 (INPUT_ENV returns NULL for set variables (CLI)).
 [2010-12-22 17:19 UTC] iliaa@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: iliaa
 [2010-12-22 17:19 UTC] iliaa@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2011-07-19 11:42 UTC] sksimpson at securemissionsolutions dot com
This issue is still open. I built 5.3.6 on RHEL 6. The code change was applied but my test result is still NULL.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 05:03:21 2014 UTC