php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52191 any PHP version above 5.3.0 causes Apache above 2.2.11 to die on start
Submitted: 2010-06-26 13:41 UTC Modified: 2010-07-07 10:43 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: therealloonylion at yahoo dot co dot uk Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 5.3.2 OS: Windows XP/2003
Private report: No CVE-ID:
 [2010-06-26 13:41 UTC] therealloonylion at yahoo dot co dot uk
Description:
------------
Not sure if this is PHP or Apache (or both), but upgrading PHP beyond 5.3.0 or Apache beyond 2.2.11 causes Apache to refuse to start (using Apache module). Apache log has '[crit] (OS 6)The handle is invalid.  : master_main: create child process failed. Exiting.', but I'm not sure if its related or not.

I've tried virtually every combination of PHP > 5.3.0 and Apache > 2.2.11. Tried on two different machines and several different OSes (XP professional SP3, 2k3 enterprise sp2 and 2k3 standard sp2). I had a friend try an XAMMP package on his machine a while back and it had exactly the same issue. I usually do a standard installation (defaults except for phpmanual and an install path of w:\php)

I'm going to raise a bug on the Apache bug tracker as well since I really don't know which package is at fault.

I am confident with computers (though programming is not my field) so feel free to ask for further information, and I'll do my best to provide it. I am only able to test on Win XP Pro, as my 2k3 standard system is a production server, and I don't currently have a 2k3 enterprise machine

Test script:
---------------
N/A


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-26 15:49 UTC] felipe@php.net
-Status: Open +Status: Feedback -Package: Apache2 related +Package: Reproducible crash
 [2010-06-26 15:49 UTC] felipe@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2010-06-26 19:13 UTC] therealloonylion at yahoo dot co dot uk
-Status: Feedback +Status: Open
 [2010-06-26 19:13 UTC] therealloonylion at yahoo dot co dot uk
It seems to no longer occur with PHP 5.3.2 although it did last time I tried it (a month or so ago) and when it first was released (tested on Apache 2.2.13 and 2.2.14 at the time). It still occurs with 5.3.1, however, so I have attached backtraces from tests with that version and the following version matrix:


Apache 2.2.11	2.2.13	2.2.14	2.2.15
PHP
5.3.0    W	   W	  W	  W
5.3.1	 NW	   NW	  NW	  NW
5.3.2	 W	   W	  W	  W

W = working
NW = not working

Apache 2.2.11:

apache log:

[Sat Jun 26 15:43:39 2010] [notice] Child 5332: All worker threads have exited.
[Sat Jun 26 15:43:39 2010] [notice] Child 5332: Child process is exiting
[Sat Jun 26 15:44:23 2010] [crit] (OS 6)The handle is invalid.  : master_main: create child process failed. Exiting.
[Sat Jun 26 15:44:23 2010] [notice] Parent: Forcing termination of child process 36 


backtrace:

Thread 0 - System ID 1208
Entry point   httpd+1ecf 
Create time   26/06/2010 15:55:10 
Time spent in user mode   0 Days 0:0:0.46 
Time spent in kernel mode   0 Days 0:0:0.203 






Function     Arg 1     Arg 2     Arg 3   Source 
php5ts!php_date_get_timezone_ce+39c     00000134     7c90d99a     7c810f63    
kernel32!CreateFileA+30     ffffffff     00000003     00000134    
0x80000000`00000000     77c61aa0     0006facc     77c2c16e    
msvcrt!_unlock+15     00000004     77c2c215     005bbc80    
msvcrt!calloc+ab     00000020     00ca6924     00000000    
php5ts!zend_error+498     77c47660     77c47660     00000020    
php5ts!spprintf+19     00000020     00ca68d4     012b2288    
php5ts!php_verror+554     00000000     00000000     00000000    




PHP5TS!PHP_DATE_GET_TIMEZONE_CE+39CWARNING - DebugDiag was not able to locate debug symbols for php5ts.dll, so the information below may be incomplete.



In httpd__PID__3272__Date__06_26_2010__Time_03_55_46PM__671__Second_Chance_Exception_C0000005.dmp the assembly instruction at php5ts!php_date_get_timezone_ce+39c in W:\PHP\php5ts.dll from The PHP Group has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000045 on thread 0

Module Information 
Image Name: W:\PHP\php5ts.dll   Symbol Type:  Export 
Base address: 0x00970000   Time Stamp:  Thu Nov 19 10:17:25 2009  
Checksum: 0x00000000   Comments:   
COM DLL: False   Company Name:  The PHP Group 
ISAPIExtension: False   File Description:  PHP Script Interpreter 
ISAPIFilter: False   File Version:  5.3.1 
Managed DLL: False   Internal Name:  PHP Script Interpreter 
VB DLL: False   Legal Copyright:  Copyright © 1997-2009 The PHP Group 
Loaded Image Name:  php5ts.dll   Legal Trademarks:  PHP 
Mapped Image Name:  W:\PHP\php5ts.dll   Original filename:  php5ts.dll 
Module name:  php5ts   Private Build:   
Single Threaded:  False   Product Name:  PHP 
Module Size:  5.45 MBytes   Product Version:  5.3.1 
Symbol File Name:  php5ts.dll   Special Build:  & 

Apache 2.2.13

apache log:

[Sat Jun 26 16:25:38 2010] [warn] pid file C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?


backtrace:


Thread 0 - System ID 3396
Entry point   httpd+1ecf 
Create time   26/06/2010 16:25:38 
Time spent in user mode   0 Days 0:0:0.15 
Time spent in kernel mode   0 Days 0:0:0.265 






Function     Arg 1     Arg 2     Arg 3   Source 
php5ts!php_date_get_timezone_ce+39c     0000012c     7c90d99a     7c810f63    
kernel32!CreateFileA+30     ffffffff     00000003     0000012c    
0x80000000`00000000     77c61aa0     0006facc     77c2c16e    
msvcrt!_unlock+15     00000004     77c2c215     005bbc80    
msvcrt!calloc+ab     00000020     00ca6924     00000000    
php5ts!zend_error+498     77c47660     77c47660     00000020    
php5ts!spprintf+19     00000020     00ca68d4     012b2288    
php5ts!php_verror+554     00000000     00000000     00000000    




PHP5TS!PHP_DATE_GET_TIMEZONE_CE+39CWARNING - DebugDiag was not able to locate debug symbols for php5ts.dll, so the information below may be incomplete.



In httpd__PID__2832__Date__06_26_2010__Time_04_26_10PM__515__Second_Chance_Exception_C0000005.dmp the assembly instruction at php5ts!php_date_get_timezone_ce+39c in W:\PHP\php5ts.dll from The PHP Group has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000045 on thread 0

Module Information 
Image Name: W:\PHP\php5ts.dll   Symbol Type:  Export 
Base address: 0x00970000   Time Stamp:  Thu Nov 19 10:17:25 2009  
Checksum: 0x00000000   Comments:   
COM DLL: False   Company Name:  The PHP Group 
ISAPIExtension: False   File Description:  PHP Script Interpreter 
ISAPIFilter: False   File Version:  5.3.1 
Managed DLL: False   Internal Name:  PHP Script Interpreter 
VB DLL: False   Legal Copyright:  Copyright © 1997-2009 The PHP Group 
Loaded Image Name:  php5ts.dll   Legal Trademarks:  PHP 
Mapped Image Name:  W:\PHP\php5ts.dll   Original filename:  php5ts.dll 
Module name:  php5ts   Private Build:   
Single Threaded:  False   Product Name:  PHP 
Module Size:  5.45 MBytes   Product Version:  5.3.1 
Symbol File Name:  php5ts.dll   Special Build:  & 

Apache 2.2.14

apache log:

[Sat Jun 26 16:39:13 2010] [warn] pid file C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?


backtrace:

Thread 0 - System ID 5028
Entry point   httpd+1ecf 
Create time   26/06/2010 16:39:11 
Time spent in user mode   0 Days 0:0:0.0 
Time spent in kernel mode   0 Days 0:0:0.281 






Function     Arg 1     Arg 2     Arg 3   Source 
php5ts!php_date_get_timezone_ce+39c     0000012c     7c90d99a     7c810f63    
kernel32!CreateFileA+30     ffffffff     00000003     0000012c    
0x80000000`00000000     77c61aa0     0006facc     77c2c16e    
msvcrt!_unlock+15     00000004     77c2c215     005bbc80    
msvcrt!calloc+ab     00000020     00ca6924     00000000    
php5ts!zend_error+498     77c47660     77c47660     00000020    
php5ts!spprintf+19     00000020     00ca68d4     012c2288    
php5ts!php_verror+554     00000000     00000000     00000000    




PHP5TS!PHP_DATE_GET_TIMEZONE_CE+39CWARNING - DebugDiag was not able to locate debug symbols for php5ts.dll, so the information below may be incomplete.



In httpd__PID__516__Date__06_26_2010__Time_04_39_14PM__796__Second_Chance_Exception_C0000005.dmp the assembly instruction at php5ts!php_date_get_timezone_ce+39c in W:\PHP\php5ts.dll from The PHP Group has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000045 on thread 0

Module Information 
Image Name: W:\PHP\php5ts.dll   Symbol Type:  Export 
Base address: 0x00970000   Time Stamp:  Thu Nov 19 10:17:25 2009  
Checksum: 0x00000000   Comments:   
COM DLL: False   Company Name:  The PHP Group 
ISAPIExtension: False   File Description:  PHP Script Interpreter 
ISAPIFilter: False   File Version:  5.3.1 
Managed DLL: False   Internal Name:  PHP Script Interpreter 
VB DLL: False   Legal Copyright:  Copyright © 1997-2009 The PHP Group 
Loaded Image Name:  php5ts.dll   Legal Trademarks:  PHP 
Mapped Image Name:  W:\PHP\php5ts.dll   Original filename:  php5ts.dll 
Module name:  php5ts   Private Build:   
Single Threaded:  False   Product Name:  PHP 
Module Size:  5.45 MBytes   Product Version:  5.3.1 
Symbol File Name:  php5ts.dll   Special Build:  & 


Apache 2.2.15

apache log:

[Sat Jun 26 16:48:40 2010] [warn] pid file C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?


backtrace:

Thread 0 - System ID 4292
Entry point   httpd+1ecf 
Create time   26/06/2010 16:48:37 
Time spent in user mode   0 Days 0:0:0.31 
Time spent in kernel mode   0 Days 0:0:0.312 






Function     Arg 1     Arg 2     Arg 3   Source 
php5ts!php_date_get_timezone_ce+39c     0000012c     7c90d99a     7c810f63    
kernel32!CreateFileA+30     ffffffff     00000003     0000012c    
0x80000000`00000000     77c61aa0     0006facc     77c2c16e    
msvcrt!_unlock+15     00000004     77c2c215     005bbc80    
msvcrt!calloc+ab     00000020     00ca6924     00000000    
php5ts!zend_error+498     77c47660     77c47660     00000020    
php5ts!spprintf+19     00000020     00ca68d4     012c2288    
php5ts!php_verror+554     00000000     00000000     00000000    




PHP5TS!PHP_DATE_GET_TIMEZONE_CE+39CWARNING - DebugDiag was not able to locate debug symbols for php5ts.dll, so the information below may be incomplete.



In httpd__PID__1604__Date__06_26_2010__Time_04_48_41PM__906__Second_Chance_Exception_C0000005.dmp the assembly instruction at php5ts!php_date_get_timezone_ce+39c in W:\PHP\php5ts.dll from The PHP Group has caused an access violation exception (0xC0000005) when trying to read from memory location 0x00000045 on thread 0

Module Information 
Image Name: W:\PHP\php5ts.dll   Symbol Type:  Export 
Base address: 0x00970000   Time Stamp:  Thu Nov 19 10:17:25 2009  
Checksum: 0x00000000   Comments:   
COM DLL: False   Company Name:  The PHP Group 
ISAPIExtension: False   File Description:  PHP Script Interpreter 
ISAPIFilter: False   File Version:  5.3.1 
Managed DLL: False   Internal Name:  PHP Script Interpreter 
VB DLL: False   Legal Copyright:  Copyright © 1997-2009 The PHP Group 
Loaded Image Name:  php5ts.dll   Legal Trademarks:  PHP 
Mapped Image Name:  W:\PHP\php5ts.dll   Original filename:  php5ts.dll 
Module name:  php5ts   Private Build:   
Single Threaded:  False   Product Name:  PHP 
Module Size:  5.45 MBytes   Product Version:  5.3.1 
Symbol File Name:  php5ts.dll   Special Build:  & 


Hope this information helps and keep up the good work with PHP :)
 [2010-06-26 23:17 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2010-06-26 23:17 UTC] kalle@php.net
Hi, your backtrace doesn't seem to include all of it, like the application entry point at main(), is there any chance you can get those remaining trace bits?
 [2010-06-27 13:22 UTC] therealloonylion at yahoo dot co dot uk
-Status: Feedback +Status: Open
 [2010-06-27 13:22 UTC] therealloonylion at yahoo dot co dot uk
The only information in the backtraces that I didn't paste was:

Type of Analysis Performed   Crash Analysis 
Machine Name   SARABI 
Operating System   Windows XP Service Pack 3 
Number Of Processors   2 
Process ID   516 
Process Image   C:\Program Files\Apache Software Foundation\Apache2.2\bin\httpd.exe 
System Up-Time   05:46:54 
Process Up-Time   00:00:03 


There's an entry point in the backtraces (already pasted) but nothing about main()
 [2010-07-07 04:47 UTC] lj0425 at gmail dot com
It's still NW on
PHP 5.3.2 + Apache 2.2.15 + XP professional SP3

if comment out 
 PHPIniDir "C:/PHP/" ->
 #PHPIniDir "C:/PHP/" 
in httpd.conf ,Apache start.
 [2010-07-07 10:43 UTC] pajoye@php.net
-Status: Open +Status: Bogus
 [2010-07-07 10:43 UTC] pajoye@php.net
Duplicate of #51298
 [2010-12-20 12:18 UTC] pxjianke at hotmail dot com
only copies php5ts.dll to WINDOWS/system32,then reset apache.so it is ok.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 02:02:10 2014 UTC