php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52175 is_link() returns false for symbolic links on windows
Submitted: 2010-06-24 19:12 UTC Modified: 2010-06-24 19:14 UTC
From: o_shes01 at uni-muenster dot de Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 5.3.2 OS: Windows Vista SP2
Private report: No CVE-ID: None
 [2010-06-24 19:12 UTC] o_shes01 at uni-muenster dot de
Description:
------------
'is_link($fname)' returns 'false' on windows vista, even if the file named by $fname exists and _is_ a symbolic link, regardless of if it points to a file or a directory; 

Bug #51766 MAY also be related to this problem; 


Test script:
---------------
<?php 

// precondition: directories c:\windows and c:\temp must exist

symlink('c:\windows', 'c:\temp\win'); // the link is created successfully
var_dump(is_link('c:\temp\win'));
?>


Expected result:
----------------
bool(true)

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-24 19:14 UTC] pajoye@php.net
-Status: Open +Status: Bogus
 [2010-06-24 19:14 UTC] pajoye@php.net
Duplicate of #51766
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 02:03:34 2021 UTC