php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52050 PHP-FPM Dies after self-initiating reload
Submitted: 2010-06-11 15:34 UTC Modified: 2011-10-08 14:22 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:0 (0.0%)
From: marcus at adolfsson dot com Assigned: fat (profile)
Status: Closed Package: FPM related
PHP Version: 5.3.2 OS: fc7
Private report: No CVE-ID: None
 [2010-06-11 15:34 UTC] marcus at adolfsson dot com
Description:
------------
Just upgraded one of our machines to PHP-FPM from
http://svn.php.net/repository/php/php-src/branches/PHP_5_3/sapi/fpm
sapi/fpm with 5.3.2 stable, and everything was working fine until PHP-
FPM needed to initiate a reload.

Jun 11 00:44:54.935812 [WARNING] [pool www] child 26032 exited on
signal 7 SIGBUS after 0.000199 seconds from start
Jun 11 00:44:54.937079 [NOTICE] [pool www] child 26033 started
Jun 11 00:44:54.937113 [WARNING] [pool www] child 26033 exited on
signal 7 SIGBUS after 0.000051 seconds from start
Jun 11 00:44:54.937139 [WARNING] failed processes threshold (10 in 60
sec) is reached, initiating reload
Jun 11 00:44:55.104446 [NOTICE] reloading: execvp("/usr/sbin/php-fpm",
{"/usr/sbin/php-fpm", "--fpm-config", "/etc/php-fpm.conf"})
php-fpm: event.c:268: event_base_free: Assertion `(((&base-
>eventqueue)->tqh_first) == ((void *)0))' failed. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-11 15:36 UTC] marcus at adolfsson dot com
This is my conf file:

;;;;;;;;;;;;;;;;;;;;;
; FPM Configuration ;
;;;;;;;;;;;;;;;;;;;;;


;include=/etc/fpm.d/*.conf

;;;;;;;;;;;;;;;;;;
; Global Options ;
;;;;;;;;;;;;;;;;;;

[global]
pid = /usr/logs/php-fpm.pid
error_log = /usr/logs/php-fpm.log

; Log level
; Possible Values: alert, error, warning, notice, debug
log_level = notice

; If this number of child processes exit with SIGSEGV or SIGBUS within the time
; interval set by emergency_restart_interval then FPM will restart. A value
; of '0' means 'Off'.
; Default Value: 0
emergency_restart_threshold = 10

; Interval of time used by emergency_restart_interval to determine when
; a graceful restart will be initiated.  This can be useful to work around
; accidental corruptions in an accelerator's shared memory.
; Available Units: s(econds), m(inutes), h(ours), or d(ays)
; Default Unit: seconds
; Default Value: 0
emergency_restart_interval = 1m

; Time limit for child processes to wait for a reaction on signals from master.
; Available units: s(econds), m(inutes), h(ours), or d(ays)
; Default Unit: seconds
; Default Value: 0
process_control_timeout = 5s

; Send FPM to background. Set to 'no' to keep FPM in foreground for debugging.
; Default Value: yes
daemonize = yes

;;;;;;;;;;;;;;;;;;;;
; Pool Definitions ;
;;;;;;;;;;;;;;;;;;;;

; Multiple pools of child processes may be started with different listening
; ports and different management options.  The name of the pool will be
; used in logs and stats. There is no limitation on the number of pools which
; FPM can handle. Your system will tell you anyway :)

; Start a new pool named 'www'.
[www]

; The address on which to accept FastCGI requests.
; Valid syntaxes are:
;   'ip.add.re.ss:port'    - to listen on a TCP socket to a specific address on
;                            a specific port;
;   'port'                 - to listen on a TCP socket to all addresses on a
;                            specific port;
;   '/path/to/unix/socket' - to listen on a unix socket.
; Note: This value is mandatory.
listen = 127.0.0.1:9000

; Set listen(2) backlog. A value of '-1' means unlimited.
; Default Value: -1
listen.backlog = -1
 
; List of ipv4 addresses of FastCGI clients which are allowed to connect.
; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
; PHP FCGI (5.2.2+). Makes sense only with a tcp listening socket. Each address
; must be separated by a comma. If this value is left blank, connections will be
; accepted from any ip address.
; Default Value: any
;listen.allowed_clients = 127.0.0.1

; Set permissions for unix socket, if one is used. In Linux, read/write
; permissions must be set in order to allow connections from a web server. Many
; BSD-derived systems allow connections regardless of permissions.
; Default Values: user and group are set as the running user
;                 mode is set to 0666
;listen.owner = nobody
;listen.group = nobody
;listen.mode = 0666

; Unix user/group of processes
; Note: The user is mandatory. If the group is not set, the default user's group
;       will be used.
user = phpfm
group = phpfm

; Choose how the process manager will control the number of child processes.
; Possible Values:
;   static  - a fixed number (pm.max_children) of child processes;
;   dynamic - the number of child processes are set dynamically based on the
;             following directives:
;             pm.max_children      - the maximum number of children that can
;                                    be alive at the same time.
;             pm.start_servers     - the number of children created on startup.
;             pm.min_spare_servers - the minimum number of children in 'idle'
;                                    state (waiting to process). If the number
;                                    of 'idle' processes is less than this
;                                    number then some children will be created.
;             pm.max_spare_servers - the maximum number of children in 'idle'
;                                    state (waiting to process). If the number
;                                    of 'idle' processes is greater than this
;                                    number then some children will be killed.
; Note: This value is mandatory.
pm = static

; The number of child processes to be created when pm is set to 'static' and the
; maximum number of child processes to be created when pm is set to 'dynamic'.
; This value sets the limit on the number of simultaneous requests that will be
; served. Equivalent to the ApacheMaxClients directive with mpm_prefork.
; Equivalent to the PHP_FCGI_CHILDREN environment variable in the original PHP
; CGI.
; Note: Used when pm is set to either 'static' or 'dynamic'
; Note: This value is mandatory.
pm.max_children = 30

; The number of child processes created on startup.
; Note: Used only when pm is set to 'dynamic'
; Default Value: min_spare_servers + (max_spare_servers - min_spare_servers) / 2
;pm.start_servers = 20

; The desired minimum number of idle server processes.
; Note: Used only when pm is set to 'dynamic'
; Note: Mandatory when pm is set to 'dynamic'
;pm.min_spare_servers = 5

; The desired maximum number of idle server processes.
; Note: Used only when pm is set to 'dynamic'
; Note: Mandatory when pm is set to 'dynamic'
;pm.max_spare_servers = 35
 
; The number of requests each child process should execute before respawning.
; This can be useful to work around memory leaks in 3rd party libraries. For
; endless request processing specify '0'. Equivalent to PHP_FCGI_MAX_REQUESTS.
; Default Value: 0
pm.max_requests = 250

; The URI to view the FPM status page. If this value is not set, no URI will be
; recognized as a status page. By default, the status page shows the following
; information:
;   accepted conn    - the number of request accepted by the pool;
;   pool             - the name of the pool;
;   process manager  - static or dynamic;
;   idle processes   - the number of idle processes;
;   active processes - the number of active processes;
;   total processes  - the number of idle + active processes.
; The values of 'idle processes', 'active processes' and 'total processes' are
; updated each second. The value of 'accepted conn' is updated in real time.
; Example output:
;   accepted conn:   12073
;   pool:             www
;   process manager:  static
;   idle processes:   35
;   active processes: 65
;   total processes:  100
; By default the status page output is formatted as text/plain. Passing either
; 'html' or 'json' as a query string will return the corresponding output
; syntax. Example:
;   http://www.foo.bar/status
;   http://www.foo.bar/status?json
;   http://www.foo.bar/status?html
; Note: The value must start with a leading slash (/). The value can be
;       anything, but it may not be a good idea to use the .php extension or it
;       may conflict with a real PHP file.
; Default Value: not set
;pm.status_path = /status
 
; The ping URI to call the monitoring page of FPM. If this value is not set, no
; URI will be recognized as a ping page. This could be used to test from outside
; that FPM is alive and responding, or to
; - create a graph of FPM availability (rrd or such);
; - remove a server from a group if it is not responding (load balancing);
; - trigger alerts for the operating team (24/7).
; Note: The value must start with a leading slash (/). The value can be
;       anything, but it may not be a good idea to use the .php extension or it
;       may conflict with a real PHP file.
; Default Value: not set
;ping.path = /ping

; This directive may be used to customize the response of a ping request. The
; response is formatted as text/plain with a 200 response code.
; Default Value: pong
;ping.response = pong
 
; The timeout for serving a single request after which the worker process will
; be killed. This option should be used when the 'max_execution_time' ini option
; does not stop script execution for some reason. A value of '0' means 'off'.
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
; Default Value: 0
request_terminate_timeout = 300s
 
; The timeout for serving a single request after which a PHP backtrace will be
; dumped to the 'slowlog' file. A value of '0s' means 'off'.
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
; Default Value: 0
request_slowlog_timeout = 10s
 
; The log file for slow requests
; Default Value: /var/log/php-fpm.log.slow
slowlog = /usr/logs/slow.log
 
; Set open file descriptor rlimit.
; Default Value: system defined value
;rlimit_files = 1024
 
; Set max core size rlimit.
; Possible Values: 'unlimited' or an integer greater or equal to 0
; Default Value: system defined value
;rlimit_core = 0
 
; Chroot to this directory at the start. This value must be defined as an
; absolute path. When this value is not set, chroot is not used.
; Note: chrooting is a great security feature and should be used whenever
;       possible. However, all PHP paths will be relative to the chroot
;       (error_log, sessions.save_path, ...).
; Default Value: not set
;chroot =
 
; Chdir to this directory at the start. This value must be an absolute path.
; Default Value: current directory or / when chroot
;chdir = /var/www
 
; Redirect worker stdout and stderr into main error log. If not set, stdout and
; stderr will be redirected to /dev/null according to FastCGI specs.
; Default Value: no
catch_workers_output = yes
 
; Pass environment variables like LD_LIBRARY_PATH. All $VARIABLEs are taken from
; the current environment.
; Default Value: clean env
env[HOSTNAME] = $HOSTNAME
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp
env[OSTYPE] = $OSTYPE
env[TMPDIR] = $MACHTYPE
env[MALLOC_CHECK_] = 2

; Additional php.ini defines, specific to this pool of workers. These settings
; overwrite the values previously defined in the php.ini. The directives are the
; same as the PHP SAPI:
;   php_value/php_flag             - you can set classic ini defines which can
;                                    be overwritten from PHP call 'ini_set'.
;   php_admin_value/php_admin_flag - these directives won't be overwritten by
;                                     PHP call 'ini_set'
; For php_*flag, valid values are on, off, 1, 0, true, false, yes or no.

; Defining 'extension' will load the corresponding shared extension from
; extension_dir. Defining 'disable_functions' or 'disable_classes' will not
; overwrite previously defined php.ini values, but will append the new value
; instead.

; Default Value: nothing is defined by default except the values in php.ini and
;                specified at startup with the -d argument
;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
;php_flag[display_errors] = off
;php_admin_value[error_log] = /var/log/fpm-php.www.log
;php_admin_flag[log_errors] = on
;php_admin_value[memory_limit] = 32M
 [2010-06-11 15:40 UTC] fat@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: fat
 [2010-06-11 16:10 UTC] tony2001@php.net
-Status: Assigned +Status: Feedback
 [2010-06-11 16:10 UTC] tony2001@php.net
Please also show the output of `ldd /path/to/php-fpm`. Thanks.
 [2010-06-11 16:27 UTC] marcus at adolfsson dot com
-Status: Feedback +Status: Open
 [2010-06-11 16:27 UTC] marcus at adolfsson dot com
ldd /usr/sbin/php-fpm
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x0000003a83000000)
	libaspell.so.15 => /usr/lib64/libaspell.so.15 (0x0000003a86000000)
	libpspell.so.15 => /usr/lib64/libpspell.so.15 (0x0000003a86400000)
	librt.so.1 => /lib64/librt.so.1 (0x0000003a81800000)
	libmysqlclient.so.15 => /usr/lib64/mysql/libmysqlclient.so.15 (0x00000036a3600000)
	libmcrypt.so.4 => /usr/lib64/libmcrypt.so.4 (0x000000357ba00000)
	libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00000036a3200000)
	libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00000036a3e00000)
	libz.so.1 => /usr/lib64/libz.so.1 (0x00000035af400000)
	libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x0000003a87000000)
	libcurl.so.3 => /usr/lib64/libcurl.so.3 (0x00000035af800000)
	libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x0000003a85400000)
	libpcre.so.0 => /lib64/libpcre.so.0 (0x00000035b0400000)
	libm.so.6 => /lib64/libm.so.6 (0x0000003a80c00000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003a80800000)
	libevent-1.4.so.1 => /usr/local/lib/libevent-1.4.so.1 (0x00002aaaaaac3000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00000036a2e00000)
	libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x0000003a84400000)
	libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x0000003a83400000)
	libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x0000003a83c00000)
	libcom_err.so.2 => /lib64/libcom_err.so.2 (0x0000003a82800000)
	libssl.so.6 => /lib64/libssl.so.6 (0x00000035afc00000)
	libcrypto.so.6 => /lib64/libcrypto.so.6 (0x00000035b0800000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x0000003a82c00000)
	libidn.so.11 => /usr/lib64/libidn.so.11 (0x0000003a82000000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003a80400000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x0000003a84000000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003a84c00000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003a81000000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003a80000000)
	libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003a82400000)
	libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x0000003a84800000)
 [2010-06-12 23:31 UTC] felipe@php.net
-Status: Open +Status: Assigned
 [2010-06-13 13:02 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2010-06-13 13:02 UTC] fat@php.net
Can you also provide the libevent version and the OS you're using. Thanks
 [2010-06-14 16:11 UTC] marcus at adolfsson dot com
-Status: Feedback +Status: Open
 [2010-06-14 16:11 UTC] marcus at adolfsson dot com
Fedora Core 7, libevent-1.4.14-stable
 [2010-06-17 02:20 UTC] felipe@php.net
-Status: Open +Status: Assigned
 [2010-06-17 19:12 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2010-06-17 19:12 UTC] fat@php.net
I can't reproduce the problem. 

I tried to compile 5.3snap on rhel 5 server with libevent 1.1.14 and I have no 
problems.

Two questions:
1- does the bug appear when sending a USR2 signal to the master process 
(reloading) ?

2- Can you compile the static modules (mysql, pspell, ...) as shared modules so 
that you will be able to run FPM without any module to check if there is no bugs 
running a specific module with FPM.
 [2010-06-17 19:58 UTC] marcus at adolfsson dot com
-Status: Feedback +Status: Open
 [2010-06-17 19:58 UTC] marcus at adolfsson dot com
Manual reloads are successful

Jun 17 13:54:25.047532 [NOTICE] reloading: execvp("/usr/sbin/php-fpm", {"/usr/sbin/php-fpm", "--fpm-config", "/etc/php-fpm.conf"})
Jun 17 13:54:25.084632 [NOTICE] using inherited socket fd=14, "127.0.0.1:9000"
Jun 17 13:54:25.084986 [NOTICE] fpm is running, pid 2564

Is there a way to force the self-initiating reload to occur for testing purposes?
 [2010-06-17 20:28 UTC] fat@php.net
-Status: Open +Status: Feedback
 [2010-06-17 20:28 UTC] fat@php.net
You can try to simulate a self-initiating reload by setting: 

emergency_restart_threshold = 1
emergency_restart_interval = 10s

and kill -7 on one child process
 [2011-10-08 14:22 UTC] fat@php.net
-Status: Feedback +Status: Closed
 [2011-10-08 14:22 UTC] fat@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC