php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5205 Failed to load DSO - need to "recompile it with -DEAPI"
Submitted: 2000-06-23 18:22 UTC Modified: 2000-07-05 00:31 UTC
From: adamek at webtrio dot de Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0.0 Release OS: Linux 2.2.14 (SuSE 6.4)
Private report: No CVE-ID: None
 [2000-06-23 18:22 UTC] adamek at webtrio dot de
Building a DSO module of PHP results in the following message:

[Fri Jun 23 18:19:59 2000] [warn] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
/usr/local/apache1.3.12/bin/apachectl startssl: httpd could not be started

Commands to build the so image:
./configure --with-apxs=/usr/local/apache1.3.12/bin/apxs --with-mysql=/usr --with-gd=/usr --enable-rule=EAPI
make
make install

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-05 00:31 UTC] adamek at webtrio dot de
Problem solved ... just forgot the silly "--enable-rule=EAPI" in the configure line ... sorry about my mistake.

Thomas
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 15:01:27 2019 UTC