|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52027 NULL bytes in mysqli prepared statements
Submitted: 2010-06-09 11:22 UTC Modified: 2010-06-09 15:58 UTC
From: jamie at splooshmedia dot co dot uk Assigned:
Status: Not a bug Package: PHP-GTK related
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
 [2010-06-09 11:22 UTC] jamie at splooshmedia dot co dot uk
MySQLi prepared statements always return NULL bytes when running in PHP-GTK. This bug does not exist in WAMP environment. Normal queries work fine in PHP-GTK. My PHP-GTK/MySQL setup is fine.

Test script:
$test = null;
if($stmt = $mysqli->prepare("SELECT 'here 3' FROM saved_data LIMIT 1")) {	
	echo 'here 1';
	while($stmt->fetch()) {
                echo 'here 2';

Expected result:
here 1
here 2
string(6) "here 3"

Actual result:
here 1
here 2
string(7) "       "


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-09 15:12 UTC]
-Status: Open +Status: Bogus
 [2010-06-09 15:12 UTC]
Cannot reproduce - works perfectly here

check that you do not have the wrong libmysql being loaded (not php_mysqli.dll - but the libmysql.dll that it uses - this sounds like a client mismatch)
 [2010-06-09 15:22 UTC]
BTW - some additional debugging suggestions for your setup - testing against WAMP is irrelevant, it's a different PHP executable in a different location with different extensions and loading different dependencies

Try your mysqli on your php-gtk install, just comment out the php-gtk extension, and see if you still get the errors
 [2010-06-09 15:58 UTC] jamie at splooshmedia dot co dot uk
Thanks for your help. After getting mysql dll files from PHP 5.2.13NTS and copying them into PHP-GTK the problem has gone.. Must have been a version mismatch as you say! Strange that some functionality worked but not all.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 15:01:28 2024 UTC