php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52020 date function error
Submitted: 2010-06-08 10:51 UTC Modified: 2010-06-08 10:55 UTC
From: 117712 at gmail dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 5.2.13 OS:
Private report: No CVE-ID: None
 [2010-06-08 10:51 UTC] 117712 at gmail dot com
Description:
------------
I think this will return 2010-04-31 but no show it for me!

Test script:
---------------
echo date('Y-m-d', strtotime("-1 month 2010-05-31"));

Expected result:
----------------
echo date('Y-m-d', strtotime("-1 month 2010-05-31"));

Actual result:
--------------
echo date('Y-m-d', strtotime("-1 month 2010-05-31"));

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-08 10:55 UTC] degeberg@php.net
-Status: Open +Status: Bogus -Package: Website problem +Package: Date/time related
 [2010-06-08 10:55 UTC] degeberg@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Valid formats are explained here:
http://php.net/datetime.formats
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 03:01:28 2024 UTC