php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51926 Module mod_auth_kerb not work with libphp5 (5.3.2)
Submitted: 2010-05-27 09:47 UTC Modified: 2010-05-27 12:50 UTC
From: metaip at mail dot ru Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.3.2 OS: Fedora 8
Private report: No CVE-ID: None
 [2010-05-27 09:47 UTC] metaip at mail dot ru
Description:
------------
This question may be intended not for you, but nevertheless...

php(5.1.2) compiled as module for apache(2.2.11) with 
--with-mysql=/u02/mysql --with-apxs2=/usr/local/apache2/bin/apxs --with-pgsql=/usr/local/pgsql --with-zlib --with-gd --with-freetype-dir --with-ttf --with-jpeg-dir --with-png-dir --with-xpm-dir.
Mod_auth_kerb(http://modauthkerb.sourceforge.net) compiled as module for apache too.
Mod_auth_kerb and libphp5(5.1.2) in combined work fine.

------------------------------------------------------------------
I have upgrade php to 5.3.2.
php(5.3.2) compiled for apache with 
--with-mysql=/u02/mysql --with-apxs2=/usr/local/apache2/bin/apxs --with-pgsql=/usr/local/pgsql --with-zlib --with-gd --with-freetype-dir --enable-gd-native-ttf --with-jpeg-dir --with-png-dir --with-xpm-dir --with-readline --with-oci8 --with-mssql=/usr/local --with-openssl-dir=/usr/local/ssl --with-bz2 --with-mcrypt --enable-mbstring.
Use same mod_auth_kerb. 
Mod_auth_kerb and libphp5(5.3.2) in combined not work. In apache`s log this error - 
"gss_import_name() failed: Miscellaneous failure (, Can't open/find Kerberos configuration file)". 
In this case httpd try to use file /krb5/krb.conf (!?!?!?).
File /etc/krb5.conf exist and its correct.
Kerberos utils from command line work fine.

With php(5.1.2) httpd uses correct file /etc/krb5.conf. 
Now i must use php(5.1.2) but i need php(5.3.2). 

Please help. Thank you.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-27 12:50 UTC] degeberg@php.net
-Status: Open +Status: Bogus
 [2010-05-27 12:50 UTC] degeberg@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 20:01:29 2024 UTC