|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51726 Segmentation fault: 11 (core dumped)
Submitted: 2010-05-03 13:20 UTC Modified: 2010-05-03 21:04 UTC
From: l dot iania at sintrade dot org Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.3.2 OS: FreeBSD 7.2 and 8.0
Private report: No CVE-ID: None
 [2010-05-03 13:20 UTC] l dot iania at sintrade dot org
The bug appears everywhere using interbase extension, also running make test in 
the build directory, producing a core dump php.core. The valgrind output is:

==94843== Jump to the invalid address stated on the next line
==94843==    at 0x1243810: ???
==94843==    by 0x375079: exit (in /lib/
==94843==    by 0x81FE1FE: main (in /usr/local/bin/php)
==94843==  Address 0x1243810 is not stack'd, malloc'd or (recently) free'd

Further more, running make test, the test #7 FAILS.

Firebird installed from ports is:
firebird-client-2.0.3_3 Firebird-2 database client
firebird-server-2.0.3_3 Firebird-2 relational database (server)

# php -v
PHP 5.3.2 with Suhosin-Patch (cli) (built: May  3 2010 11:02:58)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

Test script:
Every script involving interbase. i.e.

$user = 'SYSDBA';
$password = 'masterkey';
$dbname = '/tmp/example.fdb';
$res = ibase_connect($dbname) or die(ibase_errmsg());
ibase_close($res) or die(ibase_errmsg());


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-03 16:04 UTC]
-Status: Open +Status: Feedback
 [2010-05-03 16:04 UTC]
Could you compile PHP without Suhosin and compile with --enable-debug to export the symbols and then post a backtrace from gdb here?
 [2010-05-03 17:06 UTC] l dot iania at sintrade dot org
-Status: Feedback +Status: Open
 [2010-05-03 17:06 UTC] l dot iania at sintrade dot org
Solved. I have compiled it outside the ports without Suhosin and now it seems OK.
Thank you!
So I think that the FreeBSD ports tree should be updated.
 [2010-05-03 17:09 UTC]
-Status: Open +Status: Bogus
 [2010-05-03 17:09 UTC]
Not a php bug > bogus.
 [2010-05-03 17:37 UTC] l dot iania at sintrade dot org
Yes, it's true, but I tried to rebuild the port from the port tree excluding 
Suhosin-Patch and the resulting code was always wrong. So probably the fact is 
that the scripts for building PHP in FreeBSD ports are wrong. The bogus is not in 
Suhosin-Patch but elsewhere.
 [2010-05-03 21:04 UTC]
Does it work or not? Using the sources available at

We do not maintain the FreeBSD (or any other packages), if you are experiencing issues only with the FreeBSD packages, then please report a bug to freebsd.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 09:03:49 2022 UTC