php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51594 open_basedir reports fatal error within allowed path
Submitted: 2010-04-19 00:01 UTC Modified: 2010-05-27 21:54 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: daniel at produktion203 dot se Assigned:
Status: Not a bug Package: Safe Mode/open_basedir
PHP Version: 5.3.2 OS: FreeBSD 8.0-RELEASE-p2
Private report: No CVE-ID: None
 [2010-04-19 00:01 UTC] daniel at produktion203 dot se
Description:
------------
There seems to be some problem with open_basedir in php 5.3.2 for freebsd, i used the 5.2 branch before and the exact same config worked fine then.

open_basedir reports failure eventhough im within the allowed paths

Include paths in php.ini:
include_path = ".:/usr/local/share/pear:/usr/local/lib/php/include"

Testhost in apache:
<VirtualHost *:80>
    DocumentRoot "/home/customers/produktion203/testin.se"
    ServerName testin.se
    php_admin_value open_basedir /home/customers/produktion203/testin.se:/usr/local/share/pear:/usr/local/lib/php/include:/var/tmp
</VirtualHost>


Test script:
---------------
<?php
phpinfo();

Expected result:
----------------
Show the phpinfo();

Actual result:
--------------
Warning: Unknown: open_basedir restriction in effect. File() is not within the allowed path(s): (/home/customers/produktion203/testin.se:/usr/local/share/pear:/usr/local/lib/php/include:/var/tmp) in Unknown on line 0

Fatal error: Can't load /home/customers/produktion203/testin.se/nfo.php, open_basedir restriction. in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-22 02:15 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2010-04-22 02:15 UTC] felipe@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2010-04-22 09:32 UTC] daniel at produktion203 dot se
-Status: Feedback +Status: Open
 [2010-04-22 09:32 UTC] daniel at produktion203 dot se
Sorry but i only have live servers to work with so im not able to test this out anywhere :\

So my bugtracking help kind of ends when coming to installing new versions.

But im guessing if it works for you it probably will for me too when the new version is released.
 [2010-05-12 16:06 UTC] mike@php.net
-Status: Open +Status: Feedback
 [2010-05-12 16:06 UTC] mike@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2010-05-27 21:19 UTC] daniel at produktion203 dot se
-Status: Feedback +Status: Closed
 [2010-05-27 21:19 UTC] daniel at produktion203 dot se
Just posting the solution to this problem if someone is having the same issue as me.

The problem appeared to be due to eaccelerator, you have to add --without-eaccelerator-use-inode to your configargs in your Makefile for eaccelerator and reinstall and it will all be working like a charm again
 [2010-05-27 21:54 UTC] pajoye@php.net
-Status: Closed +Status: Bogus
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 03:01:26 2019 UTC