php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51584 FPM configure build fails to honor --with-config-file-path option
Submitted: 2010-04-17 19:52 UTC Modified: 2010-12-20 12:55 UTC
From: rschultz7 at gmail dot com Assigned:
Status: Not a bug Package: FPM related
PHP Version: 5.3SVN-2010-04-17 (SVN) OS: Linux
Private report: No CVE-ID: None
 [2010-04-17 19:52 UTC] rschultz7 at gmail dot com
Description:
------------
When configuring FPM with --with-config-file-path it doesn't look for config file 
in specified location location. Instead it looks for its config in --sysconfdir.

Test script:
---------------
'./configure' '--prefix=/usr' '--build=i686-pc-linux-gnu' '--host=i686-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--prefix=/usr/lib/php5' '--mandir=/usr/lib/php5/man' '--infodir=/usr/lib/php5/info' '--libdir=/usr/lib/php5/lib' '--without-pear' '--disable-maintainer-zts' '--enable-bcmath' '--with-bz2' '--disable-calendar' '--with-curl' '--without-curlwrappers' '--without-enchant' '--disable-exif' '--enable-ftp' '--with-gettext' '--without-gmp' '--disable-intl' '--without-kerberos' '--enable-mbstring' '--with-mcrypt' '--without-mssql' '--with-onig=/usr' '--with-openssl' '--with-openssl-dir=/usr' '--disable-pcntl' '--without-pgsql' '--without-pspell' '--without-recode' '--enable-shmop' '--without-snmp' '--disable-soap' '--enable-sockets' '--without-sybase-ct' '--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm' '--with-tidy' '--disable-tokenizer' '--disable-wddx' '--disable-xmlreader' '--disable-xmlwriter' '--without-xmlrpc' '--with-xsl' '--enable-zip' '--with-zlib' '--disable-debug' '--enable-dba' '--without-cdb' '--with-db4' '--disable-flatfile' '--with-gdbm' '--disable-inifile' '--without-qdbm' '--without-freetype-dir' '--without-t1lib' '--disable-gd-jis-conv' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--without-xpm-dir' '--with-gd' '--without-interbase' '--with-mysql=mysqlnd' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-mysqli=mysqlnd' '--without-oci8' '--without-pdo-dblib' '--with-pdo-mysql=mysqlnd' '--without-pdo-pgsql' '--with-pdo-sqlite=/usr' '--without-pdo-odbc' '--with-readline' '--without-libedit' '--with-mm' '--with-sqlite=/usr' '--enable-sqlite-utf8' '--with-pcre-regex=/usr' '--with-pcre-dir=/usr' '--disable-cli' '--enable-fpm' '--with-libevent-dir=shared,/usr/lib' '--disable-cgi' '--disable-embed' '--without-apxs2' '--with-config-file-path=/etc/php/fpm-php5' '--with-config-file-scan-dir=/etc/php/fpm-php5/ext-active'

Expected result:
----------------
FPM to default look for its config file in --with-config-file-path by default

Actual result:
--------------
Looks for its config file in --sysconfdir

Patches

fpm-config-fix.patch (last revision 2010-04-17 17:53 UTC) by rschultz7 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-18 22:03 UTC] tony2001@php.net
-Status: Open +Status: Bogus
 [2010-04-18 22:03 UTC] tony2001@php.net
--with-config-file-path=PATH
                          Set the path in which to look for php.ini [PREFIX/lib]

Apparently you're wrong in your assumption that it should look for its config file in the directory where php.ini is looked for.
These are two different files, therefore a different configure option is used in this case.
 [2010-04-19 07:21 UTC] rschultz7 at gmail dot com
Yes but there is no other option to specify a different config file path for 
FPM. This was removed from the 0.6 version to what was included with SVN. It 
doesn't make sense if you wish to keep all php related config files under a 
single directory. Especially when if you don't define --with-config-file-path 
isn't defined it then defaults back to --sysconfdir. So if you say that it 
should be a different config directive then bring back the --with-fpm-conf-dir 
instead of using --sysconfdir because --sysconfdir is identified as
--sysconfdir=DIR
       read-only single-machine data in DIR [PREFIX/etc]

Nothing specifying that the FPM config is looked for here.
 [2010-12-20 12:55 UTC] jani@php.net
-Package: Tidy +Package: FPM related
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC