php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51473 DST did not change when Windows changed
Submitted: 2010-04-05 04:16 UTC Modified: 2010-04-05 04:40 UTC
From: phil at phillydog dot info Assigned:
Status: Not a bug Package: Performance problem
PHP Version: Irrelevant OS: WIN/2003 SP2
Private report: No CVE-ID: None
 [2010-04-05 04:16 UTC] phil at phillydog dot info
Description:
------------
While I know this appears to be fixed in PHP 5.1.x, I don't want to upgrade for a trivial thing.  I am using PHP 5.0.5 on WIN/2003

Daylight savings did not change when my windows clock changed.

My workaround was rather than using EST5EDT, I switched to AST4ADT

1) Why didn't PHP time simply change with Windows?
2) Can I simply update a DLL to have PHP see the new daylight savings dates as it changed TODAY (Easter) rather than a few weeks back.

Test script:
---------------
My workaround was rather than using EST5EDT, I switched to AST4ADT until time actually changes.

Expected result:
----------------
I would assume that my PHP daylight savings would adhere to when windows switches to daylight savings.

Actual result:
--------------
Daylight savings changed TODAY (Easter) rather than a few weeks back, despite windows has said Eastern DAYLIGHT Time for a few weeks now.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-05 04:40 UTC] pajoye@php.net
-Status: Open +Status: Bogus
 [2010-04-05 04:40 UTC] pajoye@php.net
Use php 5.2 and later as they support reliabe timezone data via a bundled database. 5.1 is not supported anymore since years anyway, and there are dozen of very good reasons to update to 5.2.x (security being one of them).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 15:01:23 2020 UTC