php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51471 Error in the configure script
Submitted: 2010-04-04 17:19 UTC Modified: 2012-12-10 18:09 UTC
Votes:3
Avg. Score:4.0 ± 0.8
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: joop_boonen at web dot de Assigned:
Status: Not a bug Package: PHP-GTK related
PHP Version: 5 OS: (open)SuSE
Private report: No CVE-ID: None
 [2010-04-04 17:19 UTC] joop_boonen at web dot de
Description:
------------
checking for GtkMozEmbed support... no
checking for scintilla support... no
checking for sourceview support... no
checking for spell support... no
creating main/php_gtk_ext.c
./configure: line 12851: syntax error near unexpected token `build_libtool_libs,'
./configure: line 12851: `    _LT_DECL(build_libtool_libs, enable_shared, 0,'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-04 17:28 UTC] joop_boonen at web dot de
This bugs has been found in svn297455
 [2010-04-08 14:59 UTC] auroraeosrose@php.net
-Status: Open +Status: Feedback
 [2010-04-08 14:59 UTC] auroraeosrose@php.net
That doesn't even begin to be enough information

1. What OS are you using
2. What version of PHP are you compiling against
3. If you're using svn what version of the cairo extension are you building against
4. what version of libtool is on you machine
5. how about automake versions
6. since you're using svn, did you have any problems with buildconf?  What was the output there?

Build issues area REAL pain to pin down and they need LOTS of information, not must a short snippet from your configure output
 [2010-04-08 15:39 UTC] joop_boonen at web dot de
-Status: Feedback +Status: Open -Operating System: +Operating System: (open)SuSE -PHP Version: Irrelevant +PHP Version: 5
 [2010-04-08 15:39 UTC] joop_boonen at web dot de
The svn version compiled without a problem for me. The last version that compiled without a problem was: php5-gtk-2.0.1+svn295934

1) I'm building this package for openSuSE 11.0 - 11.2 and Factory. And SLES 10 and 11.
2) The version of php is version 5.
openSuSE 11.0 5.2.5
openSuSE 11.1 5.2.6
openSuSE 11.2 5.3.0
openSuSE Factory 5.3.0
3) I'm using pecl-cairo 0.1.0
4) libtool versions
openSuSE 11.0 1.5.26
openSuSE 11.1 2.2.6
openSuSE 11.2 2.2.6
openSuSE Factory 2.2.26b
5) automake
openSuSE 11.0 1.10.1
openSuSE 11.1 1.10.1
openSuSE 11.2 1.11
openSuSE Factory need to check
6) the last version that build without a problem on openSuSE upto and including 11.2 was svn295934. After that it failed.
 [2010-04-08 15:47 UTC] joop_boonen at web dot de
I see that a newer cairo version is available (0.2.0). http://pecl.php.net/package/cairo

As i maintain the package I'll build this. And see if it's OK.
 [2010-04-08 19:38 UTC] joop_boonen at web dot de
The build with pecl cairo 0.2.0 still fails.
 [2012-12-10 18:09 UTC] auroraeosrose@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2012-12-10 18:09 UTC] auroraeosrose@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 05:01:24 2020 UTC