php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51452 'make install-sapi' tries to execute "" for litespeed, resulting in an error
Submitted: 2010-03-31 23:32 UTC Modified: 2010-07-07 22:17 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: root at mediamonks dot net Assigned: gwang
Status: Closed Package: Other web server
PHP Version: 5.3.2 OS: FreeBSD 8.0-STABLE
Private report: No CVE-ID:
 [2010-03-31 23:32 UTC] root at mediamonks dot net
Description:
------------
Litespeed SAPI generates an error on install due to make trying to execute an empty variable.

Normally a harmless error, however it results in make returning non-zero exit status. This breaks the installation from within the Litespeed webadmin.

From Makefile:

install-sapi: $(OVERALL_TARGET)   
[snip]
        @$(INSTALL_IT)

INSTALL_IT is empty, resulting in:

# make install-sapi
Installing PHP SAPI module:       litespeed
:No such file or directory
*** Error code 1 (continuing)
# make -n install-sapi
echo "Installing PHP SAPI module:       litespeed"
/usr/local/lsws/phpbuild/php-5.2.12/build/shtool mkdir -p /opt/lsws/lsphp5/bin
if test ! -r /usr/local/lsws/phpbuild/php-5.2.12/libs/libphp5.so; then  for i in 0.0.0 0.0 0; do  if test -r /usr/local/lsws/phpbuild/php-5.2.12/libs/libphp5.so.$i; then  ln -s /usr/local/lsws/phpbuild/php-5.2.12/libs/libphp5.so.$i /usr/local/lsws/phpbuild/php-5.2.12/libs/libphp5.so;  break;  fi;  done;  fi

#

Notice the empty line in the -n output.

Setting INSTALL_IT to a dummy command (INSTALL_IT="@true") in sapi/litespeed/config.m4 fixes this.

Additionally, 'make install-sapi' doesn't even really install anything for litespeed, because their webadmin scripts copy the binary directly from the build directory to where it needs to be (which is not at $prefix). As usually you'd expect a compiled binary to end up in $prefix/bin after installation I propose fixing this so it actually installs something.

Ideally the Litespeed scripts should then copy the binary from $prefix/bin instead of from the build directory.

A patch that fixes this bug is attached, it also installs the binary to $prefix/bin/lsphp.


Patches

litespeed.diff (last revision 2010-03-31 21:33 UTC) by root at mediamonks dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-31 23:43 UTC] johannes@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: gwang
 [2010-03-31 23:43 UTC] johannes@php.net
George, please look into this.
 [2010-04-01 04:18 UTC] root at mediamonks dot net
I forgot to add that I think this to be a BSD specific issue.
 [2010-07-07 22:17 UTC] gwang@php.net
-Status: Assigned +Status: Closed
 [2010-07-07 22:17 UTC] gwang@php.net
A fix similar to the patch has been added in SVN.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 00:01:21 2014 UTC