php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51415 htaccess and mbstring.func_overload does not set local value
Submitted: 2010-03-27 22:46 UTC Modified: 2010-04-26 02:53 UTC
From: giorgio dot liscio at email dot it Assigned: moriyoshi (profile)
Status: Not a bug Package: mbstring related
PHP Version: 5.3.2 OS: windows xp x64
Private report: No CVE-ID: None
 [2010-03-27 22:46 UTC] giorgio dot liscio at email dot it
Description:
------------
hi

php_value mbstring.func_overload 3

does not works on 5.3.2

in the same htaccess -absolutely working- file 

php_value mbstring.internal_encoding "UTF-8" works correctly

func_overload does not

on my host i have the same problem and my hoster absolutely thinks that is a php bug

http://www.php.net/manual/en/mbstring.overload.php#91023

buggy since 5.2.7 too

thank you in advance


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-27 22:49 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: moriyoshi
 [2010-04-26 02:53 UTC] moriyoshi@php.net
-Status: Assigned +Status: Bogus
 [2010-04-26 02:53 UTC] moriyoshi@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

mbstring.func_overload is now a system-wide setting.  In the past it was 
advertised as  per-dir, but it turned out it is not possible to implement the 
function in such way.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 02:05:52 2022 UTC