php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #51353 ZIP64 problem
Submitted: 2010-03-22 21:16 UTC Modified: 2012-07-23 17:04 UTC
Votes:9
Avg. Score:4.3 ± 0.8
Reproduced:6 of 6 (100.0%)
Same Version:3 (50.0%)
Same OS:2 (33.3%)
From: niculaantoniu at yahoo dot com Assigned: pajoye (profile)
Status: Closed Package: Zip Related
PHP Version: 5.3.2 OS: ANY
Private report: No CVE-ID: None
 [2010-03-22 21:16 UTC] niculaantoniu at yahoo dot com
Description:
------------
You can not decompress ZIP64 files
(zip files with more than 64k entries)

The libzip >= 0.9.1 does support more than 64k entries.

Test script:
---------------
No need for test script just read the libzip news section:
http://nih.at/libzip/NEWS.html
The libzip >= 0.9.1 does support more than 64k entries.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-22 21:23 UTC] johannes@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2011-01-16 02:11 UTC] magicaltux@php.net
Precision: PHP seems to be able to open files with more than 65535 files, but 
will only be able to access the 65535 first files in the archive.

libzip is BSD. The related diff (adding support for archives with more than 65535 
files) it at:
http://hg.nih.at/libzip/?cs=daa140b84947
 [2011-01-16 10:27 UTC] pajoye@php.net
Thanks for the link, I'm following the upstream changes as well. However this 
change has not yet been released and pushing unreleased patches can force me to 
maintain something that is not anymore in the upstream library.

As soon as this patch hits a release, I will merge it (along other related 
changes).
 [2011-09-20 02:07 UTC] tim dot lock at netspot dot com dot au
Hi,

Upstream version of libzip is 0.10, please include in future PHP version.

Regards,
Tim
 [2012-07-18 12:43 UTC] chris at crgs dot co dot uk
Would really like to see libzip 0.10.1 included in PHP to fix this and possibly other issues (Bug #59118, Bug #55383) - is there any reason why it can't be done?
 [2012-07-23 14:25 UTC] chris at crgs dot co dot uk
Libzip updated to 0.10.1 as at PHP 5.4.5 / PHP 5.3.15 (http://www.php.net/ChangeLog-5.php)

Many thanks!
 [2012-07-23 17:04 UTC] pajoye@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 [2012-07-23 17:04 UTC] pajoye@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 16:01:23 2020 UTC