|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51338 URL-Rewriter should not get enabled if use_only_cookies is set to 1
Submitted: 2010-03-20 16:43 UTC Modified: 2010-03-22 13:18 UTC
From: j dot jeising at gmail dot com Assigned: iliaa
Status: Closed Package: Session related
PHP Version: 5.3SVN-2010-03-20 (SVN) OS:
Private report: No CVE-ID:
 [2010-03-20 16:43 UTC] j dot jeising at gmail dot com
If session.use_only_cookies is enabled and session_use_trans_sid is enabled PHP 
sets the URL-Rewriter as an ouput handler, although there is nothing to rewrite.

The Problem is the apply_trans_sid variable in session.c, which is only set to 
zero if a cookie is found. I wrote a small patch which should fix it but somebody 
with more insight should have a look.

Test script:

ini_set('session.use_only_cookies', 1);
ini_set('session.use_trans_sid', 0);



Expected result:
    [0] => default output handler

Actual result:
    [0] => URL-Rewriter


apply_trans_sid.patch (last revision 2010-03-20 15:43 UTC) by j dot jeising at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-20 16:45 UTC] j dot jeising at gmail dot com
Should be "ini_set('session.use_trans_sid', 1);" in the test script.
 [2010-03-22 13:16 UTC]
Automatic comment from SVN on behalf of iliaa
Log: Fixed bug #51338 (URL-Rewriter is still enabled if use_only_cookies is on).
 [2010-03-22 13:18 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: iliaa
 [2010-03-23 12:51 UTC]
Automatic comment from SVN on behalf of iliaa
Log: Added test for bug #51338
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Wed Oct 07 19:01:32 2015 UTC