php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51298 TZ detection crash
Submitted: 2010-03-14 22:25 UTC Modified: 2012-11-23 08:58 UTC
Votes:57
Avg. Score:4.5 ± 0.8
Reproduced:54 of 54 (100.0%)
Same Version:39 (72.2%)
Same OS:25 (46.3%)
From: trotsky_icepick at hotmail dot com Assigned: pajoye (profile)
Status: Closed Package: Apache2 related
PHP Version: 5.3.2 OS: Windows Vista SP2
Private report: No CVE-ID: None
 [2010-03-14 22:25 UTC] trotsky_icepick at hotmail dot com
Description:
------------
Faulting application httpd.exe, version 2.2.15.0, time stamp 0x4b8fed95, faulting 
module php5ts.dll, version 5.3.2.0, time stamp 0x4b8ec7e7, exception code 
0xc0000005, fault offset 0x000f56c0, process id 0x7a0, application start time 
0x01cac3bbc20fae92.

Test script:
---------------
not applicable

Expected result:
----------------
For Apache2 not to crash

Actual result:
--------------
Apache2 crashes

Patches

not-applicable (last revision 2010-03-14 21:27 UTC by trotsky_icepick at hotmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-14 22:34 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-03-14 22:34 UTC] pajoye@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2010-03-14 23:51 UTC] trotsky_icepick at hotmail dot com
Sending you a script to reproduce the problem is pointless. I cannot even start 
Apache2 whilst the php5apache2_2.dll module is being loaded. The issue does not 
arise from trying to access .php scripts.
 [2010-03-14 23:53 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-03-14 23:53 UTC] pajoye@php.net
Double check your configuration, be sure that you don't have older DLLs lying around in your PATH. Try again by disabling all extensions in the loaded php.ini. That's a configuration problem.
 [2010-03-15 01:51 UTC] trotsky_icepick at hotmail dot com
Thanks for your help, but extensions are already disabled in php.ini, also, I 
completely deleted my old PHP installation before installing 5.3.2, so no old 
dll's could still be there.
 [2010-03-15 02:39 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-03-15 02:39 UTC] pajoye@php.net
Where did you get apache (url?) and which PHP binaries did you download (vc9, vc6)?
 [2010-03-15 02:45 UTC] trotsky_icepick at hotmail dot com
The Apache link is: http://mirrors.dedipower.com/ftp.apache.org/httpd/httpd-
2.2.15-win32-src.zip

I downloaded the VC9 thread safe version of PHP from 
http://windows.php.net/downloads/releases/php-5.3.2-Win32-VC9-x86.msi
 [2010-03-15 10:06 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-03-15 10:06 UTC] pajoye@php.net
That's a source package, did you compile apache yourselft?

Please use http://apachelounge.com binaries with VC9 builds.
 [2010-03-16 20:32 UTC] trotsky_icepick at hotmail dot com
Sorry, the Apache2 link should have been:

http://www.mirrorservice.org/sites/ftp.apache.org/httpd/binaries/win32/httpd-
2.2.15-win32-x86-openssl-0.9.8m-r2.msi
 [2010-03-16 20:58 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-03-16 20:58 UTC] pajoye@php.net
I suppose that it is the apache official version from a mirror. So you have to use the VC6 version of our binaries.

Or apachelounge.com's version for VC9.
 [2010-03-16 21:56 UTC] trotsky_icepick at hotmail dot com
Have now installed the VC6 version of PHP and still get the same problem.
 [2010-03-16 22:44 UTC] pajoye@php.net
Disable all extensions, try again to enable them one by one.

Try in CLI as well:

php -m 

and

php -m -n

Also be sure to have the PHP directory in your PATH.
 [2010-03-16 22:44 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2010-03-16 23:03 UTC] trotsky_icepick at hotmail dot com
Just re-installed php removing some of the options I had previously selected and 
now Apache starts up OK, problem seems to be solved for now.

Thanks for your help.
 [2010-03-16 23:05 UTC] pajoye@php.net
-Status: Closed +Status: Bogus
 [2010-03-20 15:12 UTC] jeftyneg at yahoo dot com
I also have same issue. I have tried installing php-5.3.2-Win32-VC9-x86.msi and php-5.2.13-Win32-VC6-x86.msi but Apache 2.2.15 always crashed when loading php5apache2_2.dll. I always can replicate this bug. I just chose the default installation of the installers.
 [2010-03-20 15:49 UTC] pajoye@php.net
Once again, do NOT use VC9 version with apache.org's binaries, never.
 [2010-03-21 13:32 UTC] jeftyneg at yahoo dot com
Thanks to your suggestion but it does not also solved the crash issue. Even VC6 version of php-5.3.2 still crashed with apache 2.2.15. Below is the steps to reproduce:
1. Install Windows XP with SP3 (Fresh Installation)
2. Install httpd-2.2.15-win32-x86-openssl-0.9.8m-r2_2.msi using default installation options(Typical).
3. Install php-5.3.2-Win32-VC6-x86.msi/php-5.3.2-Win32-VC9-x86.msi using default installation options. 
Actual Result: Apache crashed
Error signature:
szAppName : httpd.exe     szAppVer : 2.2.15.0     szModName : php5ts.dll     
szModVer : 5.3.2.0     offset : 000e6d2c
Expected Result: Apache should start successfully without problem.

I believe anyone can reproduce this bug using the steps above. I also believe that this can be considered as critical bug.
 [2010-03-21 16:40 UTC] pajoye@php.net
-Status: Bogus +Status: Feedback
 [2010-03-21 16:40 UTC] pajoye@php.net
Once again: VC9 binaries are NOT compatible with apache.org's binaries, so do not even try to reproduce a problem using them.

Can you try using the Zip instead of the PHP MSI please (manual install of PHP)? I can reproduce the problem using the Msi but have no time yet to test further (not sure what could cause this at this point).
 [2010-03-22 10:52 UTC] pajoye@php.net
-Status: Feedback +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2010-03-22 10:52 UTC] pajoye@php.net
It works well when I use the zip release (service, console using -X, etc.). It works well as well when using the MSI and running apache from the console using httpd -X, but as soon as I run apache as a service, it crashes.

Have to analyze the diffs between the two releases, if any.
 [2010-03-22 20:03 UTC] pajoye@php.net
-Status: Assigned +Status: Feedback
 [2010-03-23 13:46 UTC] jeftyneg at yahoo dot com
Sorry for late feedback.
I have already tried http://pecl2.php.net/downloads/php-windows-builds/qa/test/php-5.3.2-win32-VC6-x86-installer.msi but the problem still exists. Apache still crashed when loading php5apache2_2.dll module. Steps to reproduce are same as noted in  [2010-03-21 11:32 UTC].
 [2010-03-23 15:05 UTC] hfastt at hotmail dot com
Same problem here.
Installed Apache 2.2.15
[httpd-2.2.15-win32-x86-openssl-0.9.8m-r2.msi]
and PHP 5.2.13 [php-5.2.13-Win32-VC6-x86.msi]
(or PHP 5.3.2 [php-5.3.2-Win32-VC6-x86.msi])
on Windows XP SP3.
When I try to start Apache, it crashes with
Error signature:
szAppName : httpd.exe     szAppVer : 2.2.15.0     szModName : php5ts.dll     
szModVer : 5.2.13.13     offset : 000f352a
 [2010-03-23 16:01 UTC] pajoye@php.net
I can't reproduce it anymore, clean install for both Windows and PHP. I also tested the installer on all supported windows version with apache 2.2.15, it went like a charm.
 [2010-03-24 15:32 UTC] jeftyneg at yahoo dot com
Did you perform any special steps why you can't reproduce it anymore? Because in my case, I can always replicate the bug. Other user also can replicate the bug as noted in [2010-03-23 13:05 UTC].
OS: Windows XP with SP3(Fresh installation with updates from Microsoft)
PHP: 5.3.2
Apache: 2.2.15
Installation options used are all default.

I just can't imagine why you can't replicate the bug but in our environment, it can easily be replicated. Please tell us more about your test environment.

Thanks.
 [2010-03-28 06:39 UTC] jeftyneg at yahoo dot com
Any update of this critical issue? I think thorough testing was not performed against Apache 2.2.15 due to the fact that Apache 2.2.15 was released 2 days after PHP 5.3.2 was released. Maybe there's a compatibility issue between Apache 2.2.15 and PHP 5.3.2. I personally considered this as a critical bug because this is a blocking issue. One can't proceed with testing the PHP scripts because installation can cause Apache 2.2.15 to crash.
 [2010-03-28 12:20 UTC] pajoye@php.net
It seems to be only a problem when you use the MSI. It does not happen if you install PHP manually using the zip releases.

It also works if I completelly remove the PHP directory and run the MSI again.

As it is critical that the MSI works smoothly, it is not like you don't have alternative right now to update to 5.3.2. The MSI maintainer is investigating the problem.
 [2010-03-28 12:21 UTC] pajoye@php.net
-Status: Feedback +Status: Assigned -Assigned To: pajoye +Assigned To: jmertic
 [2010-03-29 22:35 UTC] ficcionista at gmail dot com
I'm receiving the same error. Here's what I could find out:
Installed the following on a fresh Win XP SP3 machine:
- httpd-2.2.15-win32-x86-openssl-0.9.8m-r2.msi - Defaults
- php-5.3.2-Win32-VC6-x86.msi - Defaults

As soon as I tried to start apache i get this error: "The request operation has failed":

Error signature:
szAppName : httpd.exe     szAppVer : 2.2.15.0     szModName : php5ts.dll     
szModVer : 5.3.2.0     offset : 000e6d2c 

On the Windows event viewer i got this:
Faulting application httpd.exe, version 2.2.15.0, faulting module php5ts.dll, version 5.3.2.0, fault address 0x000e6d2c.

I've also tried disabling PHP's extensions and then turning them on one by one.
Here's the only PHP config that allowed me to start apache (Crippled, but running):

Enabled extensions:
php_bz2.dll
php_curl.dll
php_gd2.dll
php_gettext.dll
php_mysql.dll
php_mysqli.dll
php_openssl.dll
php_soap.dll

Disabled extensions
php_dba.dll
php_fdf.dll
php_sockets.dll
php_tidy.dll
php_xmlrpc.dll
php_xsl.dll
php_zip.dll
php_exif.dll
php_gmp.dll
php_imap.dll
php_ldap.dll
php_mbstring.dll
php_mcrypt.dll
php_mhash.dll
php_mime_magic.dll
php_ming.dll
php_pspell.dll
php_shmop.dll
php_snmp.dll
 [2010-03-29 23:04 UTC] pajoye@php.net
As I said, please use the Zip version in the meantime.
 [2010-04-07 20:05 UTC] noxwizard at gmail dot com
I can reproduce this on Windows 7 x64 using the zipped versions.
Apache: httpd-2.2.15-win32-x86-ssl.zip (Apache Lounge)
PHP: php-5.3.2-Win32-VC9-x86.zip (Thread Safe, php.net)
No extensions enabled.

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	apache.exe
  Application Version:	2.2.15.0
  Application Timestamp:	4b916754
  Fault Module Name:	StackHash_0a9e
  Fault Module Version:	0.0.0.0
  Fault Module Timestamp:	00000000
  Exception Code:	c0000005
  Exception Offset:	004bd5c9
 [2010-04-13 15:53 UTC] kck at mail dot ru
reproducable  
Micrisof Windows Server 2003 servie pack 2 

Faulting application php.exe, version 5.2.13.13, faulting module php5ts.dll, version 5.2.13.13, fault address 0x000f351c.
 [2010-04-13 16:03 UTC] jmertic@php.net
-Assigned To: jmertic +Assigned To: pajoye
 [2010-04-13 16:03 UTC] jmertic@php.net
Sounds like this issue is in both packages, but sporadic to reproduce. Could we 
have changed any compiler options between the builds?
 [2010-04-13 16:22 UTC] pajoye@php.net
No, we did not change options.

Can you manage to get it with the zip as well? I can't.

Or maybe a back trace would be helpful.
 [2010-04-20 01:00 UTC] downtrade at gmail dot com
After installing:

httpd-2.2.15-win32-x86-no_ssl.msi
php-5.3.2-Win32-VC6-x86.msi

got this error when started Apache:

From Win XP Event Viewer:

Faulting application iexplore.exe, version 8.0.6001.18702, faulting module mshtml.dll, version 8.0.6001.18904, fault address 0x00331b8a.

Faulting application httpd.exe, version 2.2.15.0, faulting module php5ts.dll, version 5.3.2.0, fault address 0x000e6d2c.
 [2010-04-20 01:48 UTC] pajoye@php.net
It happens to be a date bug (thread safety issue). We are trying to get a fix as soon as possible.
 [2010-04-30 06:55 UTC] slowchaos at msn dot com
Had this problem with Apache 2.2.15 and PHP 5.2.13. Tried rolling back to earlier versions of PHP - back to PHP 5.2.10. Same thing. Rolled back to Apache 2.2.14 - still same issue. My apache crashes when trying to enable mysqli or mysql extension. System path is correct. Libmysql is in appropriate place. Mcrypt also crashes the server as well as a few others.
 [2010-04-30 15:43 UTC] slowchaos at msn dot com
Update.... I have Apached 2.2.15 and PHP 5.3.2 running just fine (WinXP system). I'm not sure of the difference in 5.2 and 5.3 - I'm not a nuts and bolts php guy - but all is now well in my world :)
 [2010-05-19 17:10 UTC] williams at uncc dot edu
There is still a problem with the Windows PHP binaries.  From 4/19 pajoye seems to believe it is a date bug to "fix as soon as possible". It has been a month!

I have php-5.3.2-Win32-VC6-x86 and httpd-2.2.15-win32-x86-no_ssl installed.  If I run phpinfo() (in web page) more than once (first run - get results, second or later runs within a few seconds - get crash) I get this error message:

AppName httpd.exe  AppVer 2.2.15.0  ModName php5ts.dll
ModVer 5.3.2.0  offset 001d79b5

I have searched for other versions of php5ts.dll - none
I have NOT mixed vc9 PHP with Apache

PHP seems to run okay in command-line, ie I can run phpinfo() in cmd box with no problem.  I If run as test web page I get the error.

Here are php -m /php -m -n results:

C:\>php -m
[PHP Modules]
bcmath
calendar
com_dotnet
Core
ctype
date
dom
ereg
filter
ftp
hash
iconv
json
libxml
mcrypt
mhash
mysqlnd
odbc
pcre
PDO
Phar
Reflection
session
SimpleXML
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]


C:\>php -m -n
[PHP Modules]
bcmath
calendar
com_dotnet
Core
ctype
date
dom
ereg
filter
ftp
hash
iconv
json
libxml
mcrypt
mhash
mysqlnd
odbc
pcre
PDO
Phar
Reflection
session
SimpleXML
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]

I have disabled all but core modules.
 [2010-05-19 17:18 UTC] pajoye@php.net
If you feel like you can fix this bug within days, heh, please go ahead.
 [2010-05-25 23:44 UTC] peter dot martin at spam dot la
I've got "faulting module php5ts.dll" error while starting the Apache server with PHP and Postgres in following instalation:
- httpd-2.2.15-win32-x86-openssl-0.9.8m-r2.msi
- php-5.3.2-Win32-VC6-x86.zip
httpd.conf:
- nothing unusual configured
php.ini configuration:
- set up my own php error log file error_log = "C:/PHP/logs/error.log"
- uncomment PgSQL extension

The solution for this was to modify httpd.conf as follows:
LoadModule php5_module "C:/PHP/php5apache2_2.dll"
PHPIniDir "C:/PHP"
# added
Loadfile "C:/PHP/php5ts.dll" 
Loadfile "C:/PHP/libpq.dll"

Try it and send response...:)
 [2010-05-27 19:04 UTC] chris dot groothoff at mbits dot com dot au
I have been struggling with te hsame issue on a W2K3 Server SP2. AS soon as you install the PHP 5.3.2 VC9 or V6 version the Apache server fails to start. the event log show the following error - Faulting application httpd.exe, version 2.2.15.0, faulting module php5ts.dll, version 5.3.2.0, fault address 0x000e6d2c. I have also tryied the 5.2.13 VC6 version and this also gives teh same error.
I am going to try the ZIP solution suggested, but I can see why people frefer the MSI version :-)
I did try to locate an earlier version of Apache V2.0.X, but can not find a binary download.
 [2010-05-28 00:01 UTC] ppylak at gmail dot com
In my opinion this problem is connected with loading libpq.dll, which (in present 
version) needs some other dlls to work, but these dlls aren't included in php MSI 
installer (and even in zip).
 [2010-05-28 00:19 UTC] ppylak at gmail dot com
Supplement to my previous post.
I've added to c:\PHP\ such dlls (from pgAdmin III 1.10 installation):

gssapi32.dll,
comerr32.dll,
krb5_32.dll,
libintl-8.dll,
libiconv-2.dll,
k5sprt32.dll

and line

Loadfile "C:/PHP/libpq.dll"

to httpd.conf and my Apache has started with no changes to php.ini.
 [2010-05-28 00:21 UTC] pajoye@php.net
Please, really, stop to add completely unrelated comments to this issue.

This bug is clearly identified, there is a thread safe issue with the date initialization. Every recent comments about missing DLLs are not crashes but bad configurations.
 [2010-05-30 08:49 UTC] chris dot groothoff at mbits dot com dot au
Just to let you know that the suggestion to install the ZIP version (thread safe version) of the installation + manual configuration does allow it to work properly. This would seem to suggest that it seem that the MSI installer version is doing some thing during the install. If I get a chance to pule the MSI apart, it may reveal the what it is trying to do.
I have tested version 5.2.3 and 5.2.13, both work fine when installed from the ZIP file.
BTW - I have resorted to using 5.2.13 as it contains the PHP_SNMP.DLL that was required to run CACTI as I am not sure where to get a version for 5.2.3.
 [2010-06-03 22:14 UTC] sridhar dot devulkar at roost dot com
I had the same issue and was resolved by doing the same thing that "peter dot martin at spam dot la" did.

All it was needed was to load php5ts.dll and libpq.dll through Apache.

Now accessing the php script from the command line as well as from the web page works like a charm.

BTW, my setup is this:

Operating System: Windows Vista
Apache: Apache 2.2.11
PHP: php-5.3.2-Win32-VC6-x86.zip

Thanks,
Sri.
 [2010-06-09 16:01 UTC] brad at musatcha dot com
I don't believe it, but the suggestion from peter dot martin at spam dot la also 
works for me.

Digging in my event log on Windows XP SP3, here is what I see:

Faulting application httpd.exe, version 2.2.15.0, faulting module php5ts.dll, 
version 5.3.2.0, fault address 0x000e6d2c.

The application, C:\Program Files\Apache Software 
Foundation\Apache2.2\bin\httpd.exe, generated an application error The error 
occurred on 06/09/2010 @ 08:54:48.171 The exception generated was c0000005 at 
address 00896D2C (php5ts!php_date_get_timezone_ce)

This seems to be right in line with what you are saying pajoye, so I am guessing 
that Peter's suggestion isn't really fixing the problem.
 [2010-06-22 22:07 UTC] viderbit at abv dot bg
Hi people! This is incopatibility with VM9...
Just download Apache version from http://www.apachelounge.com + oficial PHP 5.3.2 
VM9 ...

No metter zip or msi. My setup was zip apachelounge version + PHP 5.3.2 TS VM9 
msi. And Everything works great...
 [2010-07-05 22:04 UTC] chuck at bwassociates dot com
I downloaded php-5.3.2-nts-Win32-VC6-x86.zip and followed the installation instructions. No joy. Reason: There areno php5apache2_2.dll, php5apache2_2filter.dll, or php5ts.dll to be found in the zip file. Now I am curious as to why others appear to have them. 

I extracted the files from the php-5.3.2-Win32-VC6-x86.msi installer and moved the needed dlls into the manual installation. No joy. In fact the only difference now was that Apache crashed hard whereas before it merely logged that it could not find the php5apache2_2.dll.
 [2010-07-05 22:46 UTC] pajoye@php.net
Can you please stop to add totally unrelated support questions to this bug please? Don't mess with DLL, binaries, etc. if you are not sure what to do.
 [2010-07-05 23:22 UTC] chuck at bwassociates dot com
I fail to see why you believe this is an unrelated issue to the bug. The bug title is "Error when loading php5apache2_2.dll" and that is what I, along with many others, have been suffering. 

While you may believe it is a "date" issue, and that may be so, the problem exists and someone should be seriously looking at the problem rather than dismissing it with flippant remarks and snide comments. To date, I have not seen anyone respond positively to this problem or attempt to solve it.
 [2010-07-05 23:52 UTC] pajoye@php.net
Because I explained already where this exact bug comes from.

99.9999% of the other cases are only due to missing DLLs in the PATH or using the wrong DLLs (like mysql's DLL instead of php's libmysql.dll).
 [2010-07-05 23:54 UTC] pajoye@php.net
-Summary: Error when loading php5apache2_2.dll +Summary: TZ detection crash
 [2010-07-05 23:54 UTC] pajoye@php.net
Change title to do not catch all config related reports.
 [2010-07-06 02:17 UTC] chris dot groothoff at mbits dot com dot au
I fail to understand why pajoye is so negative towards the comments provided. This topic may not be a bug directly related to the application Apache or PHP (and this forum), but it is a bug preventing the installation an operation of the application caused by the installation package/process provided. pajoye indicated that the issue has been identified, but why then are people providing evidence that this issue is still causing so much concern. For me, I followed the path of using the ZIP file rather than the MSI. This would suggest that the MSI installer package has not been configured with the correct options. So would it not be fair to say that the someone need to take responsibility for this issue and 1. take a look at the MSI and 2. provide a valid resolution.
 [2010-07-06 07:57 UTC] pajoye@php.net
I'm not negative, I only try to keep the noise/signal ration as low as I can for identified bugs, like this one. The many other crash reports are usually not crashes but simply bad configurations. And bugs.php.net is not a support channel. However I happily support users on php-windows or any other support channel.

Or in your case simply wrong version of PHP, you need the thread safe version of php for Apache as Apache uses thread safe SAPIs. NTS only contains cli, fastcgi/cgi or other non thread safe SAPIs.
 [2010-07-12 20:58 UTC] remindkumar at gmail dot com
Hi all,

I am using apache 2.2.15 with SSL from Apache Lounge, and PHP 5.3.2 VC9_ts in XP SP3.

Initially everything was working fine. After encoding my php scripts using php_bcompiler.dll (Vc9 + TS), apache is crashing with faulting module: 

AppName: httpd.exe	 AppVer: 2.2.15.0	 ModName: php5ts.dll
ModVer: 5.3.2.0	 Offset: 0000bfb7

Error log:
[Mon Jul 12 14:46:15 2010] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Mon Jul 12 14:46:16 2010] [notice] Apache/2.2.15 (Win32) mod_ssl/2.2.15 OpenSSL/0.9.8m PHP/5.3.2 configured -- resuming normal operations
[Mon Jul 12 14:46:16 2010] [notice] Server built: Mar  2 2010 15:56:36
[Mon Jul 12 14:46:16 2010] [notice] Parent: Created child process 3260

Any help would be appreciated.
 [2010-07-12 21:25 UTC] pajoye@php.net
If it does not crash without this module, what makes you think that this is remotely related to this bug (Tz detection crash)? Please report a bug at pecl.php.net/bcompiler
 [2010-07-15 20:54 UTC] tegwe002 at umn dot edu
I experienced this bug as well. 

My issue was that we're running 2 versions of php and have mysql tools for 5.0 on our machine they all had php5ts.dll

I added the location of the apache php to the environment path before mysql and that worked for me.

Server:
Win 2003 SP 2
Apache 2.2.15 win32 x86 openssl
PHP 5.2.13 win32 zip install.
 [2010-07-17 03:54 UTC] remindkumar at gmail dot com
Hi all,
I found that the php_bcompiler.dll from http://downloads.php.net/pierre/
built in version 5.3.1.

I was able to build the bcompiler source and now it is working for me.

Posted this update just to clarify.
 [2010-07-26 02:00 UTC] pajoye@php.net
-Block user comment: N +Block user comment: Y
 [2012-11-23 08:58 UTC] pajoye@php.net
-Status: Assigned +Status: Closed
 [2012-11-23 08:58 UTC] pajoye@php.net
TZ detection has been completely 
removed and user must set the TZ 
now. Crash is then per se gone.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 09:03:13 2021 UTC