php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #5111 $php_errormsg is local rather than global variable
Submitted: 2000-06-18 17:10 UTC Modified: 2000-06-18 19:35 UTC
From: sp at alkor dot ru Assigned:
Status: Closed Package: Documentation problem
PHP Version: 4.0.0 Release OS: FreeBSD, probably any
Private report: No CVE-ID: None
 [2000-06-18 17:10 UTC] sp at alkor dot ru
Script & sources available at

http://cs.alkor.ru/e.php3

This bug in PHP3 & PHP4. I cannot make public PHP4
version now.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-18 19:35 UTC] rasmus at cvs dot php dot net
This is a feature, not a bug.  $php_errormsg gets set in the
current context.  If within your function you want $php_errormsg
set in the global context, just stick a:
global $php_errormsg;
at the top of your function and it will be set in the global
context.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 23:03:34 2022 UTC