php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5108 Cannot install with fdftk support
Submitted: 2000-06-18 09:34 UTC Modified: 2001-03-18 04:44 UTC
From: izauddin at magnifix dot com dot my Assigned:
Status: Closed Package: FDF related
PHP Version: 4.0.0 Release OS: Redhat 6.2
Private report: No CVE-ID: None
 [2000-06-18 09:34 UTC] izauddin at magnifix dot com dot my
Installed fdftk4_05 from Adobe. Copied the required header file fdftk.h into
/usr/local/include/FdfTk.h and the library libfdftk.so into 
/usr/local/lib/libFdfTk.so 

Run configure as follow :-
 
    ./configure --with-apxs=/usr/sbin/apxs --with-fdftk

Produce this error :


checking whether to include fdftk support... yes
checking for FDFOpen in -lFdfTk... no
configure: error: fdftk module requires fdftk 2.0

The last section of my  config.log contains the following statement :-

configure:11472: checking whether to include fdftk support
configure:11606: checking for FDFOpen in -lFdfTk
configure:11625: gcc -o conftest -g -O2  -DEAPI=1  conftest.c -lFdfTk
-lresolv
-lm -ldl -lcrypt -lnsl  -lresolv 1>&5
/usr/local/lib/libFdfTk.so: undefined reference to `_xstat'
/usr/local/lib/libFdfTk.so: undefined reference to `__setjmp'
/usr/local/lib/libFdfTk.so: undefined reference to `_fxstat'
collect2: ld returned 1 exit status
configure: failed program was:
#line 11614 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char FDFOpen();

int main() {
FDFOpen()
; return 0; }

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-20 03:58 UTC] sniper@php.net
Does this problem still persist with more recent version of php (from CVS or http://snaps.php.net) ??

--Jani
 [2000-09-03 18:17 UTC] sniper@php.net
No feedback from user. Closed.

--Jani
 [2000-12-05 21:22 UTC] mrobinso@php.net
Re-opened.
This still happens in 4.0.4RC4, exactly as stated.

 [2001-03-18 04:44 UTC] sniper@php.net
You should copy the library from this directory
in the package from Adobe:

fdftk4_05/lib/C/Unix/i586-linux/GNU3.0/

Then it works. Also, get the latest CVS checkout of PHP to 
get the working fdf extension. 

--Jani


 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Oct 21 05:01:24 2018 UTC