php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51076 race condition in shtool's mkdir -p implementation
Submitted: 2010-02-18 00:18 UTC Modified: 2013-10-07 20:51 UTC
Votes:4
Avg. Score:3.0 ± 1.4
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: geissert at debian dot org Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.3SVN-2010-02-18 (SVN) OS: *
Private report: No CVE-ID:
 [2010-02-18 00:18 UTC] geissert at debian dot org
Description:
------------
There's a race condition in shtool's mkdir -p (not yet fixed in the latest version). At Debian we got hit by it when building with -j<n>.

I've just reported it to upstream, but since php uses its local (old) copy I'm going to fix it here too.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-18 00:30 UTC] svn@php.net
Automatic comment from SVN on behalf of geissert
Revision: http://svn.php.net/viewvc/?view=revision&revision=295225
Log: Fix race condition in shtool's mkdir -p implementation (bug #51076)
 [2010-02-18 00:31 UTC] geissert@php.net
-Status: Open
+Status: Closed

This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.
 [2010-02-18 08:34 UTC] jani@php.net
-Status: Closed
+Status: Assigned

Not fixed.
 [2013-10-01 12:58 UTC] fviard at lacie dot com
Hi,

Today  mike@php.net made me angry by posting a crappy comment on my 2,5years old bug report #54205 without even fixing the issue.

This issue was so old that I completely forgot it. But now, I'm stupefied to notice that after 2 years, that issue that is resolvable with only a 5lines patch (easy to apply) is still not resolved. What are you doing?
Mike, sorry to be offensive, but do you prefer harassing people on old bugs or fixing them?

So, please close this bug soon! Thank you!
 [2013-10-01 13:55 UTC] mike@php.net
And you make me angry by wasting my time. It was just a template when marking a bug as duplicate. Stop calling people and do something yourself. You do not have to apologize for being an asshole, just don't be an asshole.
 [2013-10-01 14:11 UTC] mike@php.net
Looks like I have to apologize for being an asshole myself, some may even think I'm the only asshole here.
 [2013-10-07 16:54 UTC] fviard at lacie dot com
Hi,
So, after all, anyone to commit again the fix?
Thank you
 [2013-10-07 20:50 UTC] geissert@php.net
-Status: Assigned +Status: Verified
 [2013-10-07 20:50 UTC] geissert@php.net
Not really. My change was reverted by jani by updating to the latest version of shtool because local changes are not liked around here...

Anyway, I think it's time to deassign it from me as upstream is pretty much dead. After multiple attempts to get it fixed upstream by myself and by the Debian maintainer there hasn't been any success. Let's see who gets rids of the road blocks and how long it takes.
 [2013-10-07 20:51 UTC] geissert@php.net
-Assigned To: geissert +Assigned To:
 [2013-10-08 06:37 UTC] mike@php.net
Automatic comment on behalf of mike
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f32d2ac3aaa7d4af7c348b00ebebb9ae64955704
Log: fix bug #51076 (race condition in shtool's mkdir -p)
 [2013-10-08 06:37 UTC] mike@php.net
-Status: Verified +Status: Closed
 [2013-11-17 09:30 UTC] laruence@php.net
Automatic comment on behalf of mike
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f32d2ac3aaa7d4af7c348b00ebebb9ae64955704
Log: fix bug #51076 (race condition in shtool's mkdir -p)
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 20:02:01 2014 UTC