php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #51045 sem_get() parameter $auto_release default value not documented
Submitted: 2010-02-14 11:47 UTC Modified: 2010-02-16 07:23 UTC
From: ayzit1991 at googlemail dot com Assigned: kalle (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
 [2010-02-14 11:47 UTC] ayzit1991 at googlemail dot com
Description:
------------
The signature for sem_get() reads

resource sem_get  ( int $key  [, int $max_acquire = 1  [, int $perm = 0666  [, int $auto_release  ]]] )

For the parameter $auto_release, it is not documented:

1. how values are handled,
2. what the default value is.

For 1 my guess is, that an integer that evaluates to boolean TRUE releases the semaphore on request shutdown and an integer that evaluates to boolean FALSE does not.

For 2 my guess is, I have to look up the documentation for a version prior to the introduction of this parameter and take that behavior as the default.


Reproduce code:
---------------
---
From manual page: function.sem-get#Description
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-16 07:23 UTC] svn@php.net
Automatic comment from SVN on behalf of kalle
Revision: http://svn.php.net/viewvc/?view=revision&revision=295138
Log: Fixed bug #51045 (sem_get() parameter $auto_release default value not documented)
 [2010-02-16 07:23 UTC] kalle@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2020-02-07 06:09 UTC] phpdocbot@php.net
Automatic comment on behalf of kalle
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=70729dc1769ee0609a99a8a53945c708cdc76e5e
Log: Fixed bug #51045 (sem_get() parameter $auto_release default value not documented)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 26 14:03:36 2021 UTC