php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51000 unaligned memory access in ext/hash/hash_tiger.c
Submitted: 2010-02-10 19:24 UTC Modified: 2010-02-13 17:58 UTC
From: geissert at debian dot org Assigned:
Status: Not a bug Package: hash related
PHP Version: 5.3.1 OS: linux ia64
Private report: No CVE-ID: None
 [2010-02-10 19:24 UTC] geissert at debian dot org
Description:
------------
There's an unaligned memory access on PHP_TIGERUpdate():

context->passed += 512;



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-12 17:15 UTC] jani@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

Sorry, wrong branch in previous post. :)
 [2010-02-12 19:28 UTC] geissert at debian dot org
Re-checking this one, I don't see how that line would lead to an unaligned memory access, so I probably just copied the wrong line. If that's so, this is a duplicate of 51003.
Sorry for the noise.
 [2010-02-13 17:58 UTC] geissert@php.net
I'm closing the bug then
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 00:03:13 2021 UTC