php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50831 [FR] "empty" in french is "vide"
Submitted: 2010-01-25 04:25 UTC Modified: 2010-01-25 17:55 UTC
From: void at informance dot info Assigned:
Status: Closed Package: Translation problem
PHP Version: 5.3.1 OS: irrelevant
Private report: No CVE-ID: None
 [2010-01-25 04:25 UTC] void at informance dot info
Description:
------------
On the french page for the "empty" keyword, it's written  "nulle" instead of "vide". "non vide" should then be used instead of "non nulle".

It's extremely confusing as actually empty is not only testing against null but uses more complex test.

I have seen this error in translation only twice : in the introduction, and in the desceription.

Reproduce code:
---------------
---
From manual page: function.empty#Description
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-25 06:31 UTC] svn@php.net
Automatic comment from SVN on behalf of yannick
Revision: http://svn.php.net/viewvc/?view=revision&revision=293960
Log: Fix bug #50831
 [2010-01-25 06:32 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2010-01-25 11:25 UTC] void at informance dot info
Yannick, there is a little mistake in the new sentences, in the XML file on SVN :

"D?termine si une variable est consid?r? comme vide.", a "e" is missing at the end of "consid?r?".

I don't know if i did right opening the ticket again, but I thought that's the way to do it.

And thank you for the all the good job !
 [2010-01-25 17:55 UTC] yannick@php.net
I have already committed this typo ;)

You can view this commit here :

http://svn.php.net/viewvc/phpdoc/fr/trunk/reference/var/functions/empty.xml?r1=293962&r2=293961&pathrev=293962

About the re-opening, no problem. It's the right way to allow me to view it quickly !

Thanks again to help us by reporting this kind of bug
 [2010-01-25 17:55 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 14:01:27 2020 UTC