php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50799 No text mapping for screen
Submitted: 2010-01-19 15:57 UTC Modified: 2010-01-20 19:55 UTC
From: pmjones@php.net Assigned:
Status: Closed Package: Doc Build problem
PHP Version: 5.3.1 OS: Mac OS X 10.5.8
Private report: No CVE-ID:
 [2010-01-19 15:57 UTC] pmjones@php.net
Description:
------------
In Package_Generic_XHTML, the $mytextmap array has no entry for 'screen', meaning that the format_screen_text() method is never called.  Easy fix: add $mytextmap['screen'] = 'format_screen_text'.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-19 16:36 UTC] rquadling@php.net
Package_Generic_XHTML has 'screen' mapped to 'format_screen'.

See 
http://svn.php.net/viewvc/phd/trunk/phpdotnet/phd/Package/Generic/XHTML.
php?view=markup#l211
 [2010-01-19 16:43 UTC] pmjones@php.net
Package_Generic_XHTML has 'screen' correctly mapped to 'format_screen', but that's not the issue.

The issue is that there is is no *text* mapping for the text of 'screen' elements.  Cf. programlisting, which has a $mytextmap['programlisting'] = 'format_programlisting_text'.  Something similar is needed for 'screen'; e.g., $mytextmap['screen'] = 'format_screen_text' (which exists but is never called, afaict, since there's no mapping for it).
 [2010-01-20 10:21 UTC] rquadling@php.net
Adding debugging to ...

Package_Generic_XHTML::format_programlisting
Package_Generic_XHTML::format_programlisting_text
Package_Generic_XHTML::format_screen
Package_Generic_XHTML::format_screen_text

(methods don't exist in Package_PHP_XHTML, but do in 
Package_PEAR_XHTML

Ran a partial build for language.exceptions.

Output shows that format_programlisting and format_screen are called, 
but that format_programlisting_text and format_screen_text are never 
called.

Even with the textmap declaration.


 [2010-01-20 19:54 UTC] svn@php.net
Automatic comment from SVN on behalf of bjori
Revision: http://svn.php.net/viewvc/?view=revision&revision=293785
Log: Fixed bug#50799 (No text mapping for screen)
 [2010-01-20 19:55 UTC] bjori@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

Richard: Because those screen elements do not have text, they have 
CDATA.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 07:02:06 2014 UTC