php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #50779 README.WIN32-BUILD-SYSTEM is outdated
Submitted: 2010-01-16 12:59 UTC Modified: 2010-10-19 06:17 UTC
From: zippy1981 at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.3.1 OS: Windows
Private report: No CVE-ID:
 [2010-01-16 12:59 UTC] zippy1981 at gmail dot com
Description:
------------
I was attempting to build php 5.3.1 on my windows 7 box as per the 
directions in README.WIN32-BUILD-SYSTEM. I asked on the php windows 
mailing list (http://news.php.net/php.windows/29806) and was told I was 
building it using outdated directions. I was told the correct way to 
build it was here 
(http://wiki.php.net/internals/windows/stepbystepbuild).

Can README.WIN32-BUILD-SYSTEM be updated to refer to the new 
dependencies?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-16 22:01 UTC] bjori@php.net
We don't understand the build requirements or system.

You have to ask the Microsoft guys to update that file.
http://no.php.net/manual/en/install.windows.building.php was one of our 
best Windows know-how (not-microsoft-employee) guy shot at documenting 
the process, but the feedback he got from Microsoft employees was "this 
is crap. its all wrong".


Sorry, we simply do not know how to do this.

 [2010-01-17 00:14 UTC] zippy1981 at gmail dot com
This is certainly frustrating.

So PHP obviously gets built and used on Windows. Am I correct to assume the problem is reproducing the process is not an exact science?

If the readme cannot be overhauled, can some of the following be done:
1) Can the top of the README file note that it is outdated and to use at your own risk
2) Can a link to the more up to data (but still broken) online directions be provided. At least users can post hints and findings in the comments.

As far as asking Microsoft myself, how do I go about that? 

Thanks,

Justin Dearing
 [2010-01-17 14:26 UTC] bjori@php.net
Updated the file to say its outdated.

As for contacting the microsoft guys, try surfing around on 
http://windows.php.net

We have tried multiple times to get these docs updated, with no luck so 
far, and like I said; our last attempt was shot down and they wanted 
those docs to be reverted.

I'm sorry, you are simply on your own here.
 [2010-01-17 14:47 UTC] bjori@php.net
See also bug#46021
 [2010-01-17 23:35 UTC] pajoye@php.net
Bjori, I would really appreciate if you stay a little bit objective and stop to spread misleading informations. Thanks.
 [2010-01-18 10:40 UTC] zippy1981 at gmail dot com
Since I got this to build, I'd like to point out that installing Visual Studio did not assist with the process.

Otherwise the newer directions seemed mostly accurate.
 [2010-01-18 11:18 UTC] kalle@php.net
I can convert the docbook xml markup into the README.WIN32-BUILD-SYSTEM, after I "fixed" the current documentation.
 [2010-10-19 06:17 UTC] kalle@php.net
-Status: Assigned +Status: Bogus -Assigned To: kalle +Assigned To:
 [2010-10-19 06:17 UTC] kalle@php.net
Pierre wants this to be in the wiki as the other is not "up to date". When theres a proper guide on php.net we can convert it as I do not want to spend a whole weekend writing something that just will get deleted.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Wed Jun 28 08:01:52 2017 UTC