php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50765 Error message executing php - oci.dll was not found
Submitted: 2010-01-15 12:12 UTC Modified: 2010-03-25 20:10 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:3 (100.0%)
From: andreas dot mohr at teraport dot de Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.3.1 OS: Windows Server 2006 64bit
Private report: No CVE-ID: None
 [2010-01-15 12:12 UTC] andreas dot mohr at teraport dot de
Description:
------------
Pre-Installed php 5.2.11 running without error messages.
- Initially no oracle extensions were installed

After Updating to 5.3.1, running any php command in command window produces the error message "The application has failed to start because oci.dll was not found. Re-Installing the application might solve the "...

Reinstalled using php-5.3.1-nts-Win32-VC9-x86.msi...
...with Oracle 10 extension. Did not fix the issue...
Result: error now occurs twice when running the php version check 
Reinstalled once more...
...with 11g Extension. Did not fix the issue...
Result: error occurs three times
- disabled all extensions containing "oci" in php.ini. Found additional extension extension=php_pdo_oci.dll

In previous versions, when PDO extensions are installed no dependancy issues occured when the database (or client) behind the extension was not installed.
The necessity to install an oracle client with PHP 5.3.1 is not well documented.

So the problem is actually solved.

If PDO extension for oracle is installed, the dependancy from oci.dll should be taken care of or informed about during installation.
If installation is an update and if pdo for oracle is NOT previously installed, do not install it.
 

Reproduce code:
---------------
In php.ini of a running PHP 5.2.11, only have pdo extensions for mysql installed.

Update an installed PHP 5.2.11 to 5.3.1 (with or without oracle extensions) using the windows installer and run c:\your-path-to-php\php-cgi.exe -v in the command prompt. 

Note: pdo extension is installed (because pdo was previously installed?). Unfolding the tree reveals that the feature is fully installed, including PDO for Oracle 10g client and above. There is no awareness of this. 



Expected result:
----------------
Execute php after Update without an error message. 


Actual result:
--------------
The version info is correctly displayed - following an error message. "The application has failed to start because oci.dll was not found. Re-installing the application might solve the problem."

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-15 12:15 UTC] andreas dot mohr at teraport dot de
As mentioned: my problem is actually solved. Nevertheless i consider this to be a bug during installation.

If PDO extension for oracle is installed, the dependancy from oci.dll
should be taken care of or informed about during installation.
If installation is an update and if pdo for oracle is NOT previously
installed, do not install it (disable preset in installation  because dependancy raises an error).
 [2010-01-15 12:21 UTC] pajoye@php.net
Agreed, it should not even be installed by default.
 [2010-01-25 08:52 UTC] pajoye@php.net
John, can you disable oci by default please?

Alternatively we could add a dep. I'm not sure if oracle has a MSI for the instant client, so we could detect it.
 [2010-03-25 19:06 UTC] jmertic@php.net
-Assigned To: jmetric +Assigned To: jmertic
 [2010-03-25 20:10 UTC] jmertic@php.net
-Status: Assigned +Status: Closed
 [2010-03-25 20:10 UTC] jmertic@php.net
Verified that pdo_oci extension is not included by default in PHP 5.3.2 installer
 [2010-05-12 00:36 UTC] aklobem at gmail dot com
This problem is still in place for php-5.2.13-win32-installer.msi

Additionally the same error occurred with respect to: PHP_PDO_SQLITE, PHP_PSPELL, PHP_SYBASE_CT
 [2011-04-14 17:28 UTC] msgctr at web-slingers dot com
This bug still exists, after all this time?
 [2011-11-04 05:33 UTC] acidcow at gmail dot com
New installation in windows... (first time I've ever tried php in windows)
and am having this same issue, but am unable to resolve.
Installed from: php-5.3.8-Win32-VC9-x86

any suggestions?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 06:03:41 2022 UTC