php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #50740 Dynamic ImageJPEG documentation
Submitted: 2010-01-13 13:45 UTC Modified: 2010-01-14 19:03 UTC
From: garypaluk at hotmail dot co dot uk Assigned: kalle (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 5.3SVN-2010-01-13 (snap) OS: Windows XP
Private report: No CVE-ID: None
 [2010-01-13 13:45 UTC] garypaluk at hotmail dot co dot uk
Description:
------------
The documentation is not correct as per changes in the implementation of the GD ImageJPEG functionality. In FireFox and possible other browsers, the code produces a dead image and is replaced with the string representation of the page URL instead of the dynamically created image from the GD library.

Reproduce code:
---------------
---
From manual page: function.imagejpeg#Examples
---


Expected result:
----------------
An dynamically created image output by the GD library.

Actual result:
--------------
Textual output of the Firefox browser respresenting the page URL.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-14 02:36 UTC] kalle@php.net
Which example in paticular are you referering to?
 [2010-01-14 17:43 UTC] garypaluk at hotmail dot co dot uk
I just discovered that it was actually an issue with using PHP v5.3.0 and using 'notepad' on WinXP to write the code. I spent quite along time trying to get this to work but when my partner tried on her version of notepad++ and it worked ok.

I copied the code from notepad++ back to notepad, saved it and it was broken again so I don't know what is going on there. I was using ANSI encoding, no trailing character etc (the same as notepad++), so I'm not sure what notepad is doing but it caused me to think that it was a documentation issue when it is infact something different.


Regards

Gary
 [2010-01-14 19:01 UTC] salathe@php.net
Thank you for your feedback and best of luck getting Notepad++ to work as you want. :)
 [2010-01-14 19:03 UTC] garypaluk at hotmail dot co dot uk
Just to re-iterate incase anyone else is having the same problem. The issue is with notepad NOT notepad++.

Regards

Gary
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 00:01:26 2020 UTC