php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50641 Extension directory
Submitted: 2010-01-03 03:20 UTC Modified: 2010-01-03 09:31 UTC
From: twallis at mts dot net Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 5.2.12 OS: Windows
Private report: No CVE-ID: None
 [2010-01-03 03:20 UTC] twallis at mts dot net
Description:
------------
In the php.ini files included in the download the extensions directly is set as: extension_dir = "./"

This prevents php from working.  It took me four hours of searching until I tripped over documentation about extension_dir.  Once I chenged the line to read: extension_dir = "c:/php/ext"  the problem was fixed.

Nowhere was it stated as part of the installation procedure to change this line.

Reproduce code:
---------------
extension_dir = "./"

Expected result:
----------------
php preprocessing does not occur

Actual result:
--------------
php preprocessing does not occur

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 20:01:28 2020 UTC