php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50527 In the setup code file use of \\localhost\Admin$ creates problem
Submitted: 2009-12-18 23:33 UTC Modified: 2015-06-09 18:51 UTC
Votes:28
Avg. Score:4.1 ± 1.0
Reproduced:15 of 16 (93.8%)
Same Version:12 (80.0%)
Same OS:15 (100.0%)
From: don dot raman at microsoft dot com Assigned: cmb (profile)
Status: Wont fix Package: Windows Installer
PHP Version: 5.2.12 OS: Windows
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-12-18 23:33 UTC] don dot raman at microsoft dot com
Description:
------------
The PHP MSI while configuring IIS FastCGI on 64 bit machine uses \\localhost\Admin$ to overcome SYSWOW64 redirection. I have found machine where \\localhost\Admin$ is not reachable. This fails running of fcgiext.js script which means the FastCGI script mapping is missing on those machine. This leads to a bad user experience.

Another thing to note that this is happening with PHP5.3.1 MSI too. So this should be fixed at both the place.

Reproduce code:
---------------
There is no code to reproduce this error as the bug is in Windows MSI.

Expected result:
----------------
MSI while selected to configure IIS FastCGI should do the script mapping and add index.php to default document list.

Actual result:
--------------
Script mapping as well as index.php in default document missing.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-25 18:54 UTC] jmertic@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: jmertic
 [2010-03-25 22:11 UTC] jmertic@php.net
-Assigned To: jmertic +Assigned To: ksingla
 [2015-06-09 18:51 UTC] cmb@php.net
-Status: Assigned +Status: Wont fix -Assigned To: ksingla +Assigned To: cmb
 [2015-06-09 18:51 UTC] cmb@php.net
This ticket is obsolete, because Microsoft installer binaries
(.msi) are not distributed anymore as of PHP 5.4.0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 13:01:24 2020 UTC