php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #50509 "make install-pear-installer" does not honor $INSTALL_ROOT
Submitted: 2009-12-17 17:27 UTC Modified: 2018-02-04 16:51 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: thomas dot parrott at jellyfish dot co dot uk Assigned: bishop (profile)
Status: Duplicate Package: *Configuration Issues
PHP Version: 5.2.12 OS: CentOS 5.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: thomas dot parrott at jellyfish dot co dot uk
New email:
PHP Version: OS:

 

 [2009-12-17 17:27 UTC] thomas dot parrott at jellyfish dot co dot uk
Description:
------------
When building PHP as an RPM, "make install-pear-installer" does not provide the ability to install in a non-root environment, but still reference root file paths like /usr/lib/php in the files generated.

Expected result:
----------------
I expect the make install-pear-installer command to provide an option for BUILD_ROOT like PHP does, in order to install files into a non-root location.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-12-18 00:33 UTC] jani@php.net
Assigned to the PEAR maintainer.
 [2010-02-20 01:00 UTC] php at group dot apple dot com
Looks like the same bug reported as https://pear.php.net/bugs/bug.php?
id=17067
 [2017-10-24 05:27 UTC] kalle@php.net
-Status: Assigned +Status: Open -Assigned To: cellog +Assigned To:
 [2018-02-04 16:51 UTC] bishop@php.net
-Status: Open +Status: Duplicate -Package: PHAR related +Package: *Configuration Issues -Assigned To: +Assigned To: bishop
 [2018-02-04 16:51 UTC] bishop@php.net
Does not seem PHAR-specific: related most to PEAR, and I agree that PEAR bug 17067 appears to cover this case. So, closing as duplicate.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Jul 19 19:01:25 2018 UTC