php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17067 Page shortcuts ignore all after the #
Submitted: 2002-05-07 05:05 UTC Modified: 2002-05-07 05:47 UTC
From: avbentem at hetnet dot nl Assigned:
Status: Closed Package: Website problem
PHP Version: 4.2.0 OS: n/a
Private report: No CVE-ID: None
 [2002-05-07 05:05 UTC] avbentem at hetnet dot nl
http://php.net/urlhowto describes page shortcuts -- but it does not   
copy the pound sign and all that follows it. 
 
The following works fine:  
 
http://www.php.net/manual/en/language.types.string.php#language.types.string.parsing     
 
However, both  
 
http://php.net/manual/en/language.types.string.php#language.types.string.parsing 
 
(note the missing www prefix) and 
 
http://www.php.net/types.string#language.types.string.parsing 
 
(note the incomplete path) are rewritten to 
 
http://www.php.net/manual/en/language.types.string.php 
 
and thus the # and all that follows it is lost.  
  
Cheers,  
Arjan van Bentem.   
-- who likes to post short links in newsgroups to  
http://www.php.net/manual/en/language.types.array.php#language.types.array.donts   
  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-07 05:47 UTC] sander@php.net
Sorry, this is not a PHP problem.
The problem is that browsers don't send anything after the #, so they just request the page 
http://www.php.net/manual/en/language.types.string.php
and after they received it, they go to the part identified by 'language.types.string.parsing'.
Apparently, when a browser is redirected to another location, it forgets everything after #.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 03:01:27 2020 UTC